Jump to content
Sign in to follow this  
cuddlyaf

no one lives forever Client MFC Application has stopped working

Recommended Posts

when i launch no one lives forever i get this error..
nolf2 works fine but nolf wont launch

Share this post


Link to post
Share on other sites

when i launch no one lives forever i get this error..

nolf2 works fine but nolf wont launch

Which error?

Share this post


Link to post
Share on other sites

Which error?

as the title says.....

Client MFC Application has stopped working

Share this post


Link to post
Share on other sites

but now it somehow works if i play at 1920x1440 resolution wich is a bit smaller than my native but it will do only now and then ill get the error.. now issue is that my cutscenes are too fast cutting out speech and end of the cutscene

Share this post


Link to post
Share on other sites

Update: aaand now im just getting a small black box or client mfc application has stopped working message...
i really love this game and would love to play it again

Share this post


Link to post
Share on other sites

 

Update: aaand now im just getting a small black box or client mfc application has stopped working message...

i really love this game and would love to play it again

 

If you are using Windows 7 or newer try running it in compatibility mode for Windows XP SP3 also right click the icon and select run as administrator.

Share this post


Link to post
Share on other sites

Would you happen to be using a G-Sync monitor? I just upgraded to one and started getting the Client MFC error. Forcing G-Sync off for the Lithtech.exe program fixed the issue.

Share this post


Link to post
Share on other sites

If you are using Windows 7 or newer try running it in compatibility mode for Windows XP SP3 also right click the icon and select run as administrator.

 

i am on windows 10pro 64bit and i have tried the compatability modes and they wont work... also tried unoffical patches and fixes that you can find in downloads here

Would you happen to be using a G-Sync monitor? I just upgraded to one and started getting the Client MFC error. Forcing G-Sync off for the Lithtech.exe program fixed the issue.

nah i have a 2560x1440 144hz freesync monitor but not using freesync since i have nvidia GTX 1070

Share this post


Link to post
Share on other sites

and if someone neeeds to know my specs.
my pc is built by me with
GTX1070
I5-6600k @4.5ghz
asus maximus gene viii mobo
custom liquid cooling loop
16gb kingston ddr4 @2666
256 samsung ssd
4tb hdd
and monitor is acer xg270hu 2560x1440 144hz

Share this post


Link to post
Share on other sites
You might try going into the Nvidia control panel, adding Lithtech.exe under Manage 3D settings -> Program Settings, and setting Monitor Technology to Fixed Refresh. (I left all the other settings at their defaults.) Nolf 1 does tend to have problems when it is running over 60fps, so it could be a possible issue.



I did have an additional problem with the game because of my dual monitor setup. I know this isn't your specific issue, but I'm adding the steps I took in case they might be of use to you.


Below is a screenshot of my primary monitor that sometimes happens when I launch Nolf 1. The game is actually displaying on the *second* monitor. The mouse and keyboard input, though are still happening on the first monitor. It is quite weird. I can fix it by setting compatibility mode to Windows XP SP2 (not SP3) and re-selecting my display resolution from the multiplayer launcher. (In this case 1920x1440.)


If re-selecting the display from the launcher doesn't work, you can edit the autoexec.cfg in the game file to force


ZChsSdy.jpg



Compatibility mode success seems to vary from person to person. Eliteone has success with one set of options and I've had success with a different set. You might have to try different combinations to see what works best for your system. :/ It's annoying enough that I've been tempted to setup a Windows XP virtual machine just for old games.

Share this post


Link to post
Share on other sites

 

You might try going into the Nvidia control panel, adding Lithtech.exe under Manage 3D settings -> Program Settings, and setting Monitor Technology to Fixed Refresh. (I left all the other settings at their defaults.) Nolf 1 does tend to have problems when it is running over 60fps, so it could be a possible issue.
I did have an additional problem with the game because of my dual monitor setup. I know this isn't your specific issue, but I'm adding the steps I took in case they might be of use to you.
Below is a screenshot of my primary monitor that sometimes happens when I launch Nolf 1. The game is actually displaying on the *second* monitor. The mouse and keyboard input, though are still happening on the first monitor. It is quite weird. I can fix it by setting compatibility mode to Windows XP SP2 (not SP3) and re-selecting my display resolution from the multiplayer launcher. (In this case 1920x1440.)
If re-selecting the display from the launcher doesn't work, you can edit the autoexec.cfg in the game file to force
ZChsSdy.jpg
Compatibility mode success seems to vary from person to person. Eliteone has success with one set of options and I've had success with a different set. You might have to try different combinations to see what works best for your system. :/ It's annoying enough that I've been tempted to setup a Windows XP virtual machine just for old games.

 

for some reason when i try to add liltech to nvidia controlpanel it crashes.. this problem occured after latest nvidia driver

Share this post


Link to post
Share on other sites

The 3rd party app, Nvidia Profile Inspector http://pcgamingwiki.com/wiki/NVIDIA_Profile_Inspector, might be a possible work around for the crashes. I haven't used it myself, so I can only say use at your own risk.

got the nvidia controlpanel to work after i did clean install of the drivers but still nothing seems to help running nolf i have googled the problem and tried every solution i could find and nothing seems to work..

sometimes (rarely) it boots up and lets me play but if i quit it wont launch again

Share this post


Link to post
Share on other sites

i even finished nolf2 while trying to fix nolf1 and i gotta say the nolf 2 was short and boring compared what nolf 1 was

Share this post


Link to post
Share on other sites

Currently struggling with this one myself
Compatibility mode isn't working, neither is locking the refresh :(

Share this post


Link to post
Share on other sites

Had the same problem, found some bits of solution with google but not everything in the same place.

Here's what's worked for me:

-in the NVIDIA control panel, go to "manage 3D settings", add nolf.exe and lithtech.exe, select NVIDIA display (if it defaulted on integrated) for both, then turn off v-sync for both

-in the NOLF folder, right click on nolf.exe, go to "compatibility" tab, select "Windows XP SP 3" compatibility and "run as administrator". Do the same for lithtech.exe

 

It seems that the game crashes if I switch resolution from the launcher, so start the game with the default settings and switch the resolution in game. On resolutions higher than 640*480 the menus were flickering really hard, you can attenuate this if you set "texture depth" to 16 instead of 32. You can still keep a x32 resolution though, it looks better in game.

 

edit: found a way to fix the flickering. In the NOLF launcher go in advanced options and add "+windowed 1" in the command line, and tick the box below it. Then I use "windowed borderless gaming" to have the game in a full screen borderless window.

Edited by loituma
  • Like 1

Share this post


Link to post
Share on other sites

Hello !

Has anyone managed to get NOLF running in a fully updated WIN 10 pro ?

Ive spent too much of my life on this, tried everything suggested in these forums and on the web.

Everytime  - Client MFC Application has stopped working

Strangely : -

NOLF 2 - works !

Contract Jack - works ! (But only by using the Project-M mod, and editing ini to 640x480 before playing everytime, then changing res in game)

Alien Vs Predator 2 - does not work, Client MFC Application has stopped working

Any fixes other than whats out there (compatabilty / run as admin / disable  virtual keyboards etc / mods / patches) ?

 

Windows error log  -

Faulting application name: lithtech.exe, version: 1.0.0.1, time stamp: 0x3ae746d9
Faulting module name: apphelp.dll, version: 10.0.15063.447, time stamp: 0x63786941
Exception code: 0xc0000005
Fault offset: 0x0001e493
Faulting process ID: 0x36d8
Faulting application start time: 0x01d32b133241885f
Faulting application path: C:\Program Files\Fox\No One Lives Forever\lithtech.exe
Faulting module path: C:\WINDOWS\SYSTEM32\apphelp.dll
Report ID: 0419f9c5-d229-4ac1-9517-a8a276704529
Faulting package full name: 
Faulting package-relative application ID: 

 

 

 

 

 

Share this post


Link to post
Share on other sites
11 hours ago, bigbilly50 said:

Hello !

Has anyone managed to get NOLF running in a fully updated WIN 10 pro ?

Ive spent too much of my life on this, tried everything suggested in these forums and on the web.

Everytime  - Client MFC Application has stopped working

Strangely : -

NOLF 2 - works !

Contract Jack - works ! (But only by using the Project-M mod, and editing ini to 640x480 before playing everytime, then changing res in game)

Alien Vs Predator 2 - does not work, Client MFC Application has stopped working

Any fixes other than whats out there (compatabilty / run as admin / disable  virtual keyboards etc / mods / patches) ?

 

Windows error log  -

Faulting application name: lithtech.exe, version: 1.0.0.1, time stamp: 0x3ae746d9
Faulting module name: apphelp.dll, version: 10.0.15063.447, time stamp: 0x63786941
Exception code: 0xc0000005
Fault offset: 0x0001e493
Faulting process ID: 0x36d8
Faulting application start time: 0x01d32b133241885f
Faulting application path: C:\Program Files\Fox\No One Lives Forever\lithtech.exe
Faulting module path: C:\WINDOWS\SYSTEM32\apphelp.dll
Report ID: 0419f9c5-d229-4ac1-9517-a8a276704529
Faulting package full name: 
Faulting package-relative application ID: 

 

 

 

 

 

GOTY version?  

Share this post


Link to post
Share on other sites

You'll want to run it in Windows 7 compatibility mode with administrative rights

Share this post


Link to post
Share on other sites

Yeah, really appreciate the response - thanks for taking the time :)

Thing is , I spent hours and hours trying all combinations of compatability settings (running as admin) with no joy :(

 

 

Share this post


Link to post
Share on other sites

I'm currently working through what may be a similar problem with NOLF 1 as discussed here.
It will help if anyone in this thread can list what devices are shown on their system. In Win 7 this info would be in Control Panel > Devices and Printers. Not sure where this is under Win 10 as I don't use it.

Share this post


Link to post
Share on other sites

What devices are you looking for? I run the games on Win 10 a custom built computer with an icore5 CPU, 24GB RAM and a 6GB Nividia GTX 1060 video card. 

I do use compatibility mode, specifically Window 7 with run as administrator. 

Share this post


Link to post
Share on other sites
1 hour ago, Eliteone said:

What devices are you looking for? I run the games on Win 10 a custom built computer with an icore5 CPU, 24GB RAM and a 6GB Nividia GTX 1060 video card. 

I do use compatibility mode, specifically Window 7 with run as administrator. 

Looking for any users with this problem running game controllers and audio devices on their systems in particular. I'm almost completely certain these things will knock out NOLF 1 on certain systems for some users. NOLF 2 remains unaffected. Need some hardware configurations of others with the problems in this thread to get an idea of where exactly the problem may be located.

Share this post


Link to post
Share on other sites
2 hours ago, Max80 said:

I'm almost completely certain these things will knock out NOLF 1 on certain systems for some users

Did I say almost? I'm dead certain now! lol

Need some more time...I'll be back...please add all your devices if you can't start NOLF in this thread along with your operating system. Brand and model details for devices would be great rather than just "got a gamepad"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.