cuddlyaf

no one lives forever Client MFC Application has stopped working

50 posts in this topic

Are you using the GOTY version of NOLF or the original? 

Share this post


Link to post
Share on other sites
On 9/12/2017 at 1:51 AM, bigbilly50 said:

NOLF 2 - works !

Contract Jack - works ! (But only by using the Project-M mod, and editing ini to 640x480 before playing everytime, then changing res in game)

Alien Vs Predator 2 - does not work, Client MFC Application has stopped working

Windows error log  -

Faulting application name: lithtech.exe, version: 1.0.0.1, time stamp: 0x3ae746d9
Faulting module name: apphelp.dll, version: 10.0.15063.447, time stamp: 0x63786941
Exception code: 0xc0000005
Fault offset: 0x0001e493
Faulting process ID: 0x36d8
Faulting application start time: 0x01d32b133241885f
Faulting application path: C:\Program Files\Fox\No One Lives Forever\lithtech.exe
Faulting module path: C:\WINDOWS\SYSTEM32\apphelp.dll
Report ID: 0419f9c5-d229-4ac1-9517-a8a276704529
Faulting package full name: 
Faulting package-relative application ID: 

 

Okey dokey, here's what I got:

Fully resolved my NOLF 1 problem. In my case it was a USB transmitter/receiver for wireless headphones that brought on the Client MFC error. If the USB was plugged in,  NOLF 1 would not launch and give the error. If I removed the USB transmitter/receiver, the game starts up perfectly. I'm on Win 7, the above quoted user is on Win 10 but I would say operating system likely doesn't matter. The issue above is very likely same as mine, everything matches up. It's looking like some legacy Windows components are causing this particular problem and the legacy components are likely the same in both operating systems. That's why this same problem could occur on both Win 7 and Win 10 along with other operating systems like Win 8.

So...if you have a start up problem similar to what is discussed here, simply unplug ALL devices to your PC except your mouse so you can actually launch the game. If you have a corded mouse you can use for testing use it. Any USB transmitters/receivers for wireless devices MUST be removed from your computer USB ports. In my case I found simply disabling the headphones via Device Manager doesn't work, the USB transmitter/receiver had to be physically removed. A computer restart after you have unplugged everything would be a good idea and then try and launch NOLF.

I've found this problem can affect more than just NOLF. It appears games released in the 2000-2003 range appear to share a similar architecture which can lead to the same issue. Poster above mentions Alien Vs Predator 2 giving the same error as NOLF and it's a very high possibility the cause of AvP2 not working is the same as it is for NOLF. Release date for AvP2 is also in the correct time period.

If you find it is a device that has caused your problem, please do post exactly what device it is! With more hardware information it may be possible to accurately track down and understand what and why it is occurring. At this point without some other hardware samples from people it's not worth it for me to waste any more time on.

Hope this helps people out! NOLF 1 is a crazy great game and should be played by all!

Edit: I should also mention I'm not confident this is the solution for the original OP but I would certainly still try it. Original OP managed to get the game semi started by messing with screen resolutions etc. I have found when it's a device problem the game is dead, won't do even a partial startup under any circumstances. However, this may not be accurate so certainly worth it for everyone with NOLF startup issues to unplug their stuff and see what happens!

Edited by Max80

Share this post


Link to post
Share on other sites

Glad you sorted it out. Were you using Windows compatibility mode as well? Curious since I used a Logitech wireless mouse and keyboard without any issues. I however run the game in compatibility mode. 

Share this post


Link to post
Share on other sites
Just now, Eliteone said:

Glad you sorted it out. Were you using Windows compatibility mode as well? Curious since I used a Logitech wireless mouse and keyboard without any issues. I however run the game in compatibility mode. 

No, no need, game runs flawlessly start to finish without doing anything special. I have a bunch of devices plugged in, Logitech keyboard and mouse as well but it was after I bought headphones I hit the problem. I didn't relate the issue to the headphones immediately as I had them for quite a while before I launched NOLF. I noticed other games weren't working either at that point and went off error logs to track things down to a few legacy areas of Windows. Put it all together and came back to the headphones.

Looking at other problem games and their forums found many instances where the same problem might be occurring to certain users. I'm quite confident this isn't a "one off" situation only occurring on my system. I'd expect it will be quite widespread.

Share this post


Link to post
Share on other sites

Oh, Eliteone, just realized you are also running Win 10 I believe where as I am running Win 7 so that may be why you need to use the compatibility modes. Win 7 runs great with AA and AF also applied. NOLF 2 stability is another story, still playing through it, gave me issues in the first couple of levels so put it on an old XP machine then later transferred back to my Win 7 machine after I finished Siberia. Messing a little with NOLF 2 as well to see if some of the crash and texture issues can be resolved. Got to play it first and for me it's not in the same class as NOLF 1 so I'm playing other games and I'll get back to it when I feel the need. lol

Share this post


Link to post
Share on other sites

MAX - thanks for the suggestions , will give this a try and report back when my hangover lets up (at a gig last night), Ive got loads of USB devices I can try unplugging (including XBOX ONE wireless receiver)

 

 

 

Share this post


Link to post
Share on other sites
56 minutes ago, bigbilly50 said:

MAX - thanks for the suggestions , will give this a try and report back when my hangover lets up (at a gig last night), Ive got loads of USB devices I can try unplugging (including XBOX ONE wireless receiver)

 

 

 

That'd be great, I'd be very interested. Make sure everything is unplugged and you don't miss anything. Looking forward to the results.

Share this post


Link to post
Share on other sites
On 10/14/2017 at 4:27 AM, bigbilly50 said:

Im guessing that this must be a Win10 specific issue - I tried booting with only keyboard plugged in - still get the same error message launching game.

Are you running it in compatibility mode? 

Share this post


Link to post
Share on other sites
On 10/16/2017 at 7:30 PM, Eliteone said:

Are you running it in compatibility mode? 

Yes, please do make sure you run appropriate settings required for Win 10 or it may not launch because of this. My USB theory is being confirmed elsewhere so please do make sure you are running appropriate settings for Win 10 and have unplugged devices as I suggested before you give up on NOLF. If you can do try Alien Vs Predator 2 as well. I'm suspecting there is a good possibility NOLF and Alien Vs Predator 2 have the same issue.

Edited by Max80

Share this post


Link to post
Share on other sites

I should also mention USB's definitely can affect Win 10 as I suspected even though I could only confirm Windows 7 myself. Windows 10 stopping games for the USB reason has been confirmed by another user for another game on another forum. 

Share this post


Link to post
Share on other sites

Thanks for the info - I did try AVP2 at the time plus all manner of compatibility combinations with no joy !

 

Gonna leave this for a bit as Ive spent faaaar too much time trying to get these to work - maybe in the future after a fresh install of windows I will have more luck.

 

Thanks again tho for the tips :)

Share this post


Link to post
Share on other sites

Just a final note on this.  Before un-installing , as a last gasp effort I tried to run NOLF one last time.  At the 3rd attempt it ran !   Instead of playing , I exited and tried to run again, MAKING NO CHANGES - same old error.

I cold booted my PC and replicated the exact same combination of resolution / compatibility etc - maybe after an hour or so of trying, again it ran.  And again after exiting the game, it would gave the same error when trying to run again.  No matter how many times I tried.  

I tried for maybe another hour of resetting my PC but no joy. (Im sure if I spent longer , I *may* have got it to run once more.)

Too random and too time consuming Im afraid.

Tried the above for AVP2 and it would not run a single time.

Hopefully sometime in the future there will be a definitive fix.

 

 

Share this post


Link to post
Share on other sites

SORTED !!!!!!!!!!!!!!!

As Max suggested , it WAS to do with USB devices !  However, unplugging them made no difference for me.

I had to DISABLE every "HID COMPLIANT VENDOR DEFINED DEVICE" in device manager to get NOLF AND AVP2 to work.

I had about 6 of these in device manager , through process of elimination I know now that there is ONE of these I need to disable to get both games to work.

Compatability settings etc make zero difference to me - if this device is disabled , then the games run instantly (only played NOLF for a bit but seems to run fine at 4K)

I feel like partying !!  (about to pour a gin !)

Special thanks to Max for pointing me in the right direction.

Cheers all !

 

Edit - for reference, the offending driver is AndroidAFDx64.sys

 

 

Edited by bigbilly50

Share this post


Link to post
Share on other sites

Also worth mentioning *after spending several hours actually PLAYING these games*.  They are very good, and well worth any FPS players time. Much more so than the recent COD for example.  Entertaining, and still look half decent !  NOLF grabbing me more than NOLF2 due to less emphasis on stealth.

Blood 2 / SHOGO - not so sure yet :) 

Share this post


Link to post
Share on other sites

Excellent Billy! I'm still working and monitoring this particular USB related problem. Appears there are slight variations on different systems as you have found on yours. Thanks for reporting back because this really helps continue to piece things together.

Agree on NOLF 1, found it to be a brilliant game! Don't think I ever enjoyed a game so much start to finish.

Share this post


Link to post
Share on other sites

Billy, if you read this can you just let me know if your PC might be an Alienware PC by any chance?

Share this post


Link to post
Share on other sites

So I had this same issue on a Win7 machine. Running in WinXP compatibility mode and as administrator did nothing. WHat worked was unplugging a USB device. Sepcifically a Pickit 3 from Microchip, which is used to program PIC microcontrollers.

If it is plugged in, I get the MFC error. If not, it starts up right away like a champ.

Share this post


Link to post
Share on other sites
22 hours ago, jeffry7 said:

So I had this same issue on a Win7 machine. Running in WinXP compatibility mode and as administrator did nothing. WHat worked was unplugging a USB device. Sepcifically a Pickit 3 from Microchip, which is used to program PIC microcontrollers.

If it is plugged in, I get the MFC error. If not, it starts up right away like a champ.

Fantastic! Thanks for posting the info. This USB issue has likely wiped out the ability for so many people to play these old games for a very long time. Anyone else who can specifically name problem devices please do. If you have to use Billy's method and disable the USB through device manager please make mention if you have an Alienware PC.

Edited by Max80

Share this post


Link to post
Share on other sites

getting this error trying to fix the game as well

work it out was my usb headset

Edited by Massamo

Share this post


Link to post
Share on other sites
On 1/27/2018 at 6:32 AM, Massamo said:

getting this error trying to fix the game as well

work it out was my usb headset

Thanks for the info. Can you provide the make and model of the headset?

Share this post


Link to post
Share on other sites

Ok gents. Wanted to chip in here, as I finally got my NOLF 1 GOTY up and running yesterday on Windows 10 Pro 1709 (Fall Creator's Update; FCU) on my Alienware 17 R2 laptop (incl. an  Alienware Graphics Adapter (AGA), containing an EVGA GTX 1080 Ti) with a 3440 x 1440 x 32 resolution.

I was struggling a lot at first, all the time running into the "Client MFC Application has stopped working" error. Here is the setup that finally did it for me:

  • Compatibility settings on both the NOLF.exe and the lithtech.exe files to XP SP 2. No other compatibility would do it for me.
  • Running both these files as admin.
  • Installed DirectX 8 (although I think it didn't make a difference - but listing it here nevertheless).
  • Nothing checked / all unchecked in the "Advanced..." section of the NOLF.exe launcher.
  • Within the "Display..." section, on startup I  always have to choose a lower than my 3440 x 1440 x 32 resolution. Launching it at this resolution setting will result (yet again) in the "Client MFC Application has stopped workingerror. So I choose my EVGA GTX 1080 Ti on the left hand side (as opposed to "Primary Display Driver"), and as the initial resolution 1024 x 768 x 32.
  • This allows me to launch the game - and I afterwards in game can change the resolution to 3440 x 1440 x 32.

In case anyone is interested, the important settings of my NVIDIA Control panel:

  • As opposed to what is mentioned on https://pcgamingwiki.com/wiki/The_Operative:_No_One_Lives_Forever, I did not turn off G-SYNC. NOLF 1 GOTY runs on my rig with it enabled.
  • I limited my monitor's refresh rate to 60 Hz.
  • In the "Manage 3D settings" section, I added the lithtech.exe under the "Program Settings" tab.
  • Preferred graphics processor = High-performance NVIDIA processor
  • Specific settings for lithtech.exe: I deliberately disabled V-sync (thus overriding my global settings).

Just a quick sidenote: Within the launcher window of NOLF.exe, I can only successfully click either the "Display..." or the "Advanced..." button. Once I have been in either of their sub-menus, clicking on the other button will not result in anything. So I normally click "Advanced..." first, then quit the launcher - and after re-launching it go into the "Display..." section, then immediately launch the game itself. I later never have to go into the "Advanced..." section again - but the "Display..." section every time (as described above) upon launch.

Thought I'd list these steps here in case anyone is as frustrated as I was during set up.

Cheers

 

Edited by cmaesing
added url

Share this post


Link to post
Share on other sites

Another way with Nvidia cards is run it in windowed mode. 

Good write up B)

Share this post


Link to post
Share on other sites

Just wanted to confirm an earlier finding: disconnecting my wireless USB headset receiver made the game launch properly. As for playing it well... still working on that!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now