Sign in to follow this  
KillySG10

GOTY Win 10 wont start

Recommended Posts

So, i recently wanted to replay the NOLF again, but ran into a hitch, launcher will open, but when i hit launch the game wont run, it'll open in a tiny box for like a split second then nothing.

 

It does this vanilla install, it does it with no cd, widescreen patch (any of the 3), multiplayer launcher, mouse and stutter fix, any combination thereof (i've spent hours trying)

I've tried it in any compatibility mode, with and without run as admin and so far, same every time.

 

Any help appreciated.

Share this post


Link to post
Share on other sites

So, i recently wanted to replay the NOLF again, but ran into a hitch, launcher will open, but when i hit launch the game wont run, it'll open in a tiny box for like a split second then nothing.

 

It does this vanilla install, it does it with no cd, widescreen patch (any of the 3), multiplayer launcher, mouse and stutter fix, any combination thereof (i've spent hours trying)

I've tried it in any compatibility mode, with and without run as admin and so far, same every time.

 

Any help appreciated.

 

Did you install the original GOTY media or?

I'd recommend using the media we have in our downloads, patching it and then using the NOLF multi-player launcher from our downloads as well.

Sounds like you've downloaded a bundled set of media that isn't remotely standard.

I use the GOTY from our site with Windows 10 Pro and the multi-player launcher.

Share this post


Link to post
Share on other sites

 

Did you install the original GOTY media or?

I'd recommend using the media we have in our downloads, patching it and then using the NOLF multi-player launcher from our downloads as well.

Sounds like you've downloaded a bundled set of media that isn't remotely standard.

I use the GOTY from our site with Windows 10 Pro and the multi-player launcher.

I installed from the GOTY discs i have, i was beginning to worry they might be damaged.

 

I have however tried the GOTY isos from the downloads as you suggest, and i get the same results, with no cd and launcher.

 

EDIT: i saw a post in another thread mentioning installing DX7, but the setup on the disc leaves the option greyed out, and i dled an installer for it, and it says its not compatible with this version of windows. I have tried installing DX9 to see if that worked, still no luck.

Edited by KillySG10

Share this post


Link to post
Share on other sites

What kind of computer are you using? A laptop or a desktop? Integrated graphics or dedicated card?

 

Sorry if those are things you've already researched. I'm just trying to make sure we have a better idea of what you're working with. :)

Share this post


Link to post
Share on other sites

Im on Desktop with a GTX 970.

 

If i remember correctly, the last time i played the game i was on win 7 with the same GTX 970, different machine though.

Share this post


Link to post
Share on other sites

Thanks.

 

I'm using a 980 with the latest drivers, which is close enough to your 970. I've disabled the introduction movies in the launcher and set my resolution to 1600x1200x32, if that helps. The only other option I have checked is "Always pass command line arguments to the game".

Share this post


Link to post
Share on other sites

Just to give an update to anyone else who might come across this, it appeared to be a driver issue causing conflict in ntdll.dll. I checked the event log and found it was causing the crash, even though windows wasn't telling me as such, the event logs listed it as such, fiddling with drivers did the trick.

 

EDIT: Never mind, it ran once now its straight back to crashing...

Edited by KillySG10

Share this post


Link to post
Share on other sites

What else is it saying in your event logs about the crashing?

Share this post


Link to post
Share on other sites

Its just listed as an application error with event id 1000, the most generic of events, with the faulting module being ntdll.dll, and all i've managed to find on it is that its usually driver related, or corrupted. I've run an sfc scan so i can rule out corruption, and updating and rolling back audio and graphics drivers has so far led to it running once before immediately going back to crashing.

 

Just to note, the application it refers to is lithtech.exe, not nolf.exe, so it seems to not be the launcher, but the engine itself.

Edited by KillySG10

Share this post


Link to post
Share on other sites

If you have the CDs, does the game load that way? That is, without the No CD crack. I seem to remember that some of the No CD cracks no longer work correctly. This way we can see if it is the crack vs the game itself.

Share this post


Link to post
Share on other sites

Yeah, it happens without any modifications, with disc 2 in.

 

EDIT: On a side note, i just tried playing the original Red Faction, another game i haven't played in years, has an incredibly similar problem. Probably not related specifically, but from what i read on that, seems some games have issues on win 10 since the anniversary update. Alas i have no way of knowing if it's that, messing with specific windows updates is a real hassle.

Edited by KillySG10

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this