Jettary

black screen when going underwater

28 posts in this topic

So I managed to find the cause of the problem, its the Nvidia Optimus, I play it on both PC and my laptop and found that on PC it's work just fine but except on laptop that has a black screen problem. I think that the issue come from the Intel driver, because the game using Intel Graphic Display rather than NVIDIA itself, I test this both with Intel Graphic installed and not, result is if I not install the Intel Graphic Driver the black screen issue will be solved but the game will run extremely lag

 

so to conclusion, if I can make a game run through the gpu display rather than cpu display, this issue will fix

 

the new driver surely dont like old game

Share this post


Link to post
Share on other sites

This is such helpful info, THANK YOU! I think I'm going to have to try and fix my old desktop just to play it there are so many problems along with this one since getting my new laptop x___x

Share this post


Link to post
Share on other sites

Look likes I manage to find a fix for this black screen underwater, the files from 'dgVoodoo 2' which fix this problem so if anyone still have a problem with this, use this file from https://community.pcgamingwiki.com/files/file/572-dgvoodoo-2/ and copy D3D8.dll , D3DImm.dll and DDraw.dll to <path-to-game>.

 

Edited by Jettary

Share this post


Link to post
Share on other sites
20 hours ago, Jettary said:

Look likes I manage to find a fix for this black screen underwater, the files from 'dgVoodoo 2' which fix this problem so if anyone still have a problem with this, use this file from https://community.pcgamingwiki.com/files/file/572-dgvoodoo-2/ and copy D3D8.dll , D3DImm.dll and DDraw.dll to <path-to-game>.

 

Nice find. I've added it to our downloads here

Share this post


Link to post
Share on other sites

Those files can work in other games as well. I haven't had any issues with NOLF but came across issues in other games. Blacks textures are often a problem in other games and those voodoo files tend to be the fix. Some virus software might have a fit over the old dll's but they are completely safe.

  • Like 1

Share this post


Link to post
Share on other sites
On 28/6/2017 at 8:40 PM, Jettary said:

Look likes I manage to find a fix for this black screen underwater, the files from 'dgVoodoo 2' which fix this problem so if anyone still have a problem with this, use this file from https://community.pcgamingwiki.com/files/file/572-dgvoodoo-2/ and copy D3D8.dll , D3DImm.dll and DDraw.dll to <path-to-game>.

 

Sorry but you can explain more specific the thing about dgvoodoo and how to install it? English is not my first language  soo

Share this post


Link to post
Share on other sites

From Play Old PC Games: 

We we the file in our downloads HERE

dgVoodoo is a legacy DirectX and 3DFX Glide wrapper program. The purpose of this software is to translate or wrap function calls to old, legacy graphics API (application programming interface) functions into calls to the much more modern Direct3D 11. In other words, it acts as a translator, changing old games to run with newer, modern graphics techniques. Using the wrapper is very easy, and you can try it with any game that uses DirectX or Direct Draw versions 1 to 8, or any game that uses 3DFX/Glide. Of course, since this software uses Direct3D 11, you will need a graphics card or chip capable of using this version of DirectX.

To get started, download the latest version from the gdVoodoo homepage here. At the time of writing, the latest version was v2.43. The file is downloaded as a zip file, once downloading is complete, open the zip file in file explorer. You should see the following folders.

 

dgvoodoo2-zip

 

If you’re trying dgVoodoo with a DirectX game, then you should open the “MS” sub folder and copy all the contents to your games installation directory. If you’re trying a 3DFX/Glide game, then copy all the files from the 3DFX folder instead. Do NOT under any circumstances copy the dll files inside the MS folder to your PCs system directories (anywhere within the Windows folder).

Finally, copy the dgVoodooSetup.exe file into your games installation folder too. This makes it easier to configure dgVoodoo for your specific game.

Running dgVoodoo

As long as you copied the .dll files to your games installation folder correctly, all that you need to do to run the game in dgVoodoo mode is to simply start it. Of course, not every game is compatible, so it’s usually just a matter of trying the game out and seeing if it works. To remove dgVoodoo from a game, just delete the .dll files you copied in.

Configuring dgVoodoo

You can configure dgVoodoo by running the dgVoodooSetup.exe program from within your games installation folder. Technically this program doesn’t need to be in your games installation folder, but it is the easiest way to use it. Run the program and the following window will appear.

 

dgvoodoo-arcanum

 

Before you get started, click on the button circled in red in the picture above. This makes sure the configuration file is written to the correct folder.

The options that you configure are generally set on a per-game basis and may need some experimentation. There is one important option you may wish to change for every game however. Over on the DirectX tab there’s the option “dgVoodoo Watermark”. This applies a watermark to the games graphics in the bottom right hand corner of the screen. While you are configuring dgVoodoo we recommend leaving this option on, as it is a good indicator that the wrapper is working correctly. Once you are happy that everything is configured and working, you can then disable the watermark and play your game.

Other benefits

Since dgVoodoo makes old games use newer versions of DirectX, it can also enable compatibility with certain in-game tools and utilities. For instance, when a game is running through the dgVoodoo wrapper, it becomes compatible with the Nvidia 

Share this post


Link to post
Share on other sites

This is all very useful, however, I need some input. I right- click on the on the games shortcut and click on the "open file location" option, and it shows me all the games files and the like. Which file do I put the dgvoodoo codes in? Just the file I mentioned, or somewhere else?

Share this post


Link to post
Share on other sites
8 hours ago, AgentJay94 said:

This is all very useful, however, I need some input. I right- click on the on the games shortcut and click on the "open file location" option, and it shows me all the games files and the like. Which file do I put the dgvoodoo codes in? Just the file I mentioned, or somewhere else?

For NOLF GOTY you would copy the .dll files to C:\Program Files\Fox\No One Lives Forever    

For the original I believe it is c:\Program Files (x86) Fox

Share this post


Link to post
Share on other sites

Thank you Eliteone, but unfortunately, I have discovered another problem.

I downloaded dgvooodoo2 through the link above, and when I unzip the contents, I get this...

 image.png.881622c7c0ae156036ab7556f858d2cc.png

As you can see, it looks nothing like the images above, and I have no idea why.

This is for everyone, has anyone else run into this issue? If so, how did you solve it?

Any input is much appreciated

UPDATE: I solved it. The problem was I was downloading from dgvoodoos official site, not the link provided through the forum. For those having the same issue, download the program through this link: 

 

Edited by AgentJay94
Update to situation

Share this post


Link to post
Share on other sites

Glad you got it sorted B)

Share this post


Link to post
Share on other sites

Hey guys,

So I have the same problem, I copied the files to my game path, but when I try and run the game, the game window goes black and it doesn't even run the game at all. Does anyone have a solution for this?

Share this post


Link to post
Share on other sites
1 hour ago, KateArcher02 said:

Hey guys,

So I have the same problem, I copied the files to my game path, but when I try and run the game, the game window goes black and it doesn't even run the game at all. Does anyone have a solution for this?

Can you provide your Windows version, machine specs etc? 

Share this post


Link to post
Share on other sites
8 minutes ago, Eliteone said:

Can you provide your Windows version, machine specs etc? 

Sure thing,

I have Windows 10 Home, version 10.0.16299

The laptop I'm using is a Dell Inspiron 3737, with an Intel Core i5-4200U

Share this post


Link to post
Share on other sites

Do you know what it's using for graphics? 

Share this post


Link to post
Share on other sites

I have a similar issues with dgvoodoo2. I dont know whether its the game files I'm using or dgvoodoo2 itself.

My computer is a ASUS Transformer Flipbook with the following...

Processor: Intel Core i5-5200U CPU @ 2.20 GHz

RAM: 8 GB

Graphics Card: Nvidia GeForce 820m with 1999 MB of video memory

I hope this info is of use to you.

 

Share this post


Link to post
Share on other sites
3 hours ago, AgentJay94 said:

I have a similar issues with dgvoodoo2. I dont know whether its the game files I'm using or dgvoodoo2 itself.

My computer is a ASUS Transformer Flipbook with the following...

Processor: Intel Core i5-5200U CPU @ 2.20 GHz

RAM: 8 GB

Graphics Card: Nvidia GeForce 820m with 1999 MB of video memory

I hope this info is of use to you.

 

The Nvidia should be compatible. Reason I ask is some Intel integrated graphics have issues with the T & L hardware settings for these games. 

Can you try the game in windowed mode and see if that resolves it?

Share this post


Link to post
Share on other sites

Thank you Eliteone, the windowed mode works with dgvoodoo, but now the mouse wont move. Any thoughts?

UPDATE: Again I found the issue. Through some experimentation, i found that the mouse wont work if you change the window resolution during gameplay.

Edited by AgentJay94

Share this post


Link to post
Share on other sites

Sorry for not checking back for a year, and unclear explanation.

To any of those who still have a problem with this black screen

and lazy to go configuration dgVoodoo,

> I've upload my config here :: http://www.mediafire.com/file/esi8wflsgwnxnu1/FixBlackScreen.rar

Just copy into game directory, I've provided the picture so that will make it more easier.

 

- I don't know about the 'mouse not working' problem but I'll take a look for it later.

- This files that I uploaded are also can be use for NOLF2 (Black-screen problem: Try getting shot with poison and see what happen)

- This files use on GOTY Version > for normal version = I don't know bro.

 

Try this with 'disable movies' in advance setting and select display setting as 'dgVoodoo DirectX Wrapper'

I don't know if the widescreen resolution will cause the problem, so I always play 4:3 ratio.

 

I'll be in touch, so leave a comment if you occurred any problems. 

peace.

Edited by Jettary

Share this post


Link to post
Share on other sites

Pictures here

twattutorial.jpg

anotherone.jpg

alsoonemore.jpg

Share this post


Link to post
Share on other sites

I tried everything and still have the same problem :(

Share this post


Link to post
Share on other sites
4 hours ago, bucko said:

I tried everything and still have the same problem :(

 

Have you downloaded this and this?

Share this post


Link to post
Share on other sites
5 hours ago, Eliteone said:

 

Have you downloaded this and this?

Yes and yes and unfortunately nothing works.
Could the Widescreen patch be causing the problem?

It even won't start in windowed mode, and I'm sure I added the command line the right way. Also, when I start the launcher I can click on Display and then when I click on Advanced there is no response, and vice versa. 

Edited by bucko

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now