Sign in to follow this  
rabidclam

Frame rate Drop When Zooming on the sniper

9 posts in this topic

I seem to have weird frame rate drops whenever I zoom in with a sniper rifle, or press the switch function keys. I've installed the Stutter/Frame Rate fix, but it hasn't solved the issue. Any one know how to resolve it?

Share this post


Link to post
Share on other sites

I seem to have weird frame rate drops whenever I zoom in with a sniper rifle, or press the switch function keys. I've installed the Stutter/Frame Rate fix, but it hasn't solved the issue. Any one know how to resolve it?

I have the same issues with the GOTY Edition (running on Windows 10 64 bit with jackfuste's widescreen patch). So far I managed to find nothing on this sadly, seems like Win 10 just has a problem with the game. 'frell' WB for not letting Night Dive remaster the game, seriously.

Share this post


Link to post
Share on other sites

I'm having this issue on Windows 10 as well, along with the fact that the framerate stutters heavily whenever any popups occur, mostly when I'm swapping ammo types. Anyone got a fix for this?

 

Seems like there's a DrawDLL or something for Windows 8 but it doesn't seem to be there for Windows 10.

Share this post


Link to post
Share on other sites

I'm having this issue on Windows 10 as well, along with the fact that the framerate stutters heavily whenever any popups occur, mostly when I'm swapping ammo types. Anyone got a fix for this?

 

Seems like there's a DrawDLL or something for Windows 8 but it doesn't seem to be there for Windows 10.

 

I have to run NOLF 1 in windowed mode on Windows 10. That seems to help. Might give that a try.

Share this post


Link to post
Share on other sites

 

I have to run NOLF 1 in windowed mode on Windows 10. That seems to help. Might give that a try.

I tried that, but it didn't really help. Running in Windowed helped on Windows 8.1 along with fellow LithTech game AVP2, but it didn't seem to help with NOLF1 (bizzarely, AVP2 runs fine on fullscreen on Windows 10 for me).

 

EDIT: In case something I listed might explain some of the issues I'm having:

 

I installed the NOLF1 Revival copy that's bundled with the widescreen patch off http://nolfrevival.tk.

 

I'm using max settings on everything, running it at 1920x1080 and pushed texture resolution to max.

 

I run the game in Steam as a non-Steam game to check my framerate, but the laggy feeling exists even if I run the exe directly.

 

I tried using the compatibility settings with MS Compatibility Administrator which didn't really help. It might have helped make it somewhat playable, but the laggy feeling is still there and the framerate drops in both scopes and pop ups are still there.

 

Running the game in compatibility mode for Windows 8, 7, XP etc. didn't help, neither did Administrator.

 

Windowed mode didn't really help.

 

I imported LithTech.exe into NVidia profiles to try and force VSync, framerate limits, and other stuff into the game. While it works at doing so, it didn't really help with the lag or framedrops.

 

Also, another bizarre thing: the game feels laggy when I bring up pop up menus (such as swapping ammo) but the Steam overlay claims I'm getting 100+ FPS (I normally keep VSync on, so the game is set at my monitor's refresh rate: 75FPS), so apparently my framerate is actually increasing, not decreasing.

 

The only thing that somewhat worked was boosting mouse smoothing to the absolute max, but even then, some laggy feeling exists. Like sometimes, I'd move the mouse but the crosshair itself wouldn't move, making lining up precise shots kind of difficult.

 

So yeah, I'm kind of at a loss here. :\

 

EDIT 2: I tried Windowed mode again with max mouse smoothing and that seems to be less jerky than max mouse smoothing with fullscreen. Still doesn't fix the scope drops or the pop up menu jerkiness but the core shooting feels tolerable now. At least for now. I wonder if DGVoodoo would work at solving some of these issues.

 

EDIT 3: Huh, DGVoodoo 2 seems to actually work. After I put the D3D files from DGVoodoo 2 into the game, put the game in Windowed mode and put mouse smoothing to max, now the game seems to run smooth enough and the framerate issues when popups occur no longer happen. Frame drops still occur with scopes, but the drops are significantly lower. Before, it'd normally be 75 FPS and drop to 40 FPS, now it's dropping only to 60FPS, which is perfectly playable. I'm not sure if it requires everything I mentioned, but right now the game seems playable. I even manage to make the Windowed mode borderless with the Borderless Gaming program. The only issue now is I think DGVoodoo doesn't play well with Alt Tab, so if I Alt Tab the game will crash. But otherwise, it's perfectly playable for me now. Thanks for the help and this might be worth noting for future people who have issues.

Edited by gameragodzilla

Share this post


Link to post
Share on other sites

I tried that, but it didn't really help. Running in Windowed helped on Windows 8.1 along with fellow LithTech game AVP2, but it didn't seem to help with NOLF1 (bizzarely, AVP2 runs fine on fullscreen on Windows 10 for me).

 

EDIT: In case something I listed might explain some of the issues I'm having:

 

I installed the NOLF1 Revival copy that's bundled with the widescreen patch off http://nolfrevival.tk.

 

I'm using max settings on everything, running it at 1920x1080 and pushed texture resolution to max.

 

I run the game in Steam as a non-Steam game to check my framerate, but the laggy feeling exists even if I run the exe directly.

 

I tried using the compatibility settings with MS Compatibility Administrator which didn't really help. It might have helped make it somewhat playable, but the laggy feeling is still there and the framerate drops in both scopes and pop ups are still there.

 

Running the game in compatibility mode for Windows 8, 7, XP etc. didn't help, neither did Administrator.

 

Windowed mode didn't really help.

 

I imported LithTech.exe into NVidia profiles to try and force VSync, framerate limits, and other stuff into the game. While it works at doing so, it didn't really help with the lag or framedrops.

 

Also, another bizarre thing: the game feels laggy when I bring up pop up menus (such as swapping ammo) but the Steam overlay claims I'm getting 100+ FPS (I normally keep VSync on, so the game is set at my monitor's refresh rate: 75FPS), so apparently my framerate is actually increasing, not decreasing.

 

The only thing that somewhat worked was boosting mouse smoothing to the absolute max, but even then, some laggy feeling exists. Like sometimes, I'd move the mouse but the crosshair itself wouldn't move, making lining up precise shots kind of difficult.

 

So yeah, I'm kind of at a loss here. :\

 

EDIT 2: I tried Windowed mode again with max mouse smoothing and that seems to be less jerky than max mouse smoothing with fullscreen. Still doesn't fix the scope drops or the pop up menu jerkiness but the core shooting feels tolerable now. At least for now. I wonder if DGVoodoo would work at solving some of these issues.

 

EDIT 3: Huh, DGVoodoo 2 seems to actually work. After I put the D3D files from DGVoodoo 2 into the game, put the game in Windowed mode and put mouse smoothing to max, now the game seems to run smooth enough and the framerate issues when popups occur no longer happen. Frame drops still occur with scopes, but the drops are significantly lower. Before, it'd normally be 75 FPS and drop to 40 FPS, now it's dropping only to 60FPS, which is perfectly playable. I'm not sure if it requires everything I mentioned, but right now the game seems playable. I even manage to make the Windowed mode borderless with the Borderless Gaming program. The only issue now is I think DGVoodoo doesn't play well with Alt Tab, so if I Alt Tab the game will crash. But otherwise, it's perfectly playable for me now. Thanks for the help and this might be worth noting for future people who have issues.

 

Not familiar with that site or what they may have done to the program.

Not sure of the legality of distributing it that way either.

I do know you can still buy the game via Amazon or Ebay

So their argument about it not being able to be purchased is incorrect.

Share this post


Link to post
Share on other sites

 

Not familiar with that site or what they may have done to the program.

Not sure of the legality of distributing it that way either.

I do know you can still buy the game via Amazon or Ebay

So their argument about it not being able to be purchased is incorrect.

Ah okay, well I will endeavor to try and grab a copy from that way then, though it's sad I can't easily grab a digital copy off GOG or something.

 

Either way, DGVoodoo2 seems to have fixed the issue so if someone in the future has issues, could tell them about that.

Share this post


Link to post
Share on other sites

 

 

DGVoodoo2 seems to have fixed the issue so if someone in the future has issues, could tell them about that.

If you'd like to write it up (The steps for DGVoodoo2) We'd be glad to feature it :)

Share this post


Link to post
Share on other sites

If you'd like to write it up (The steps for DGVoodoo2) We'd be glad to feature it :)

Alright, I'll write it here:

 

To install DGVoodoo 2:

 

1. Download the files from http://dege.freeweb.hu/dgVoodoo2_53.zip (there might be a false flagging by anti-virus software but it isn't a virus).

 

2. When downloaded, there are two folders (MS and 3Dfx) and the dgVoodoo.exe file.

 

3. Because NOLF1 is Direct3D, copy all the files in the MS folder (D3D8.dll, D3DImm.dll and DDraw.dll) into the NOLF folder holding the Lithtech.exe file. Copying DGVoodoo.exe isn't necessary.

 

4. Open DGVoodoo.exe and click the Add button. Navigate to the folder you put all the files in and hit Select Folder.

 

5. Now there will be a specific profile for NOLF that you can fiddle around under the DirectX tab.

 

That should fix all the issues, though there are a few things to keep in mind.

 

"Disable and passthru to real DirectX" will disable the emulation and cause it to not function.

 

Forcing bilinear filtering and linear mip filtering could cause some artifacting on letters.

 

Antialiasing caused some not insigificant frame drops for me, so use with caution.

 

I have Force VSync on which I don't know if it was what fixed the issue, but I have it on with no problems.

 

I don't know what Apply Phong Shading is, but I have it on with no problems either.

 

Fast video memory access and bilinear blit stretch gave me weird artifacts in Splinter Cell, but that's a different game on a different engine to NOLF. I kept them off just in case.

 

Obviously, turn off the dgVoodoo watermark so it doesn't ugly up the game.

 

And that's about it as far as I know. All I know is I put the files in there and now the issues have mostly been resolved. The fps jerkiness from pop up menus is gone and while there are still framedrops for using the scope, the framedrops are significantly smaller, dropping merely to 60fps from my usual monitor refresh rate of 75 Htz. Mouse smoothing still needs to be maxed out and the game still needs to be run in Windowed mode for maximum smoothness, but now it's completely playable. The only issue at the moment is that Alt Tab seems to cause my game to crash.

 

As a side note:

 

To get Borderless Windowed (basically faked Fullscreen look):

 

1. Download Borderless Gaming from here: https://github.com/Codeusa/Borderless-Gaming then open the program

 

2. Run NOLF1 in Windowed mode.

 

3. Select NOLF from the Applications Window and move it to Favorites, which will automatically make the game borderless as soon as it launches.

 

4. The Borderless Gaming program can be hidden out of the way into the tray, so it can just run in the background and automatically make NOLF play like in Windowed mode but look Fullscreen

 

5. The launcher might also be stretched out, which is awkward but not too big a deal, I think.

 

Being that this requires Alt Tabbing in order to set it up, it's a good idea to do this first and then do the dgVoodoo later as Alt Tabbing with dgVoodoo seems to crash the game.

 

Hope you got all that giant wall of text. lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this