Welcome to The Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads

Sign in to follow this  
Devan

Win 7 Unable to patch to 1.3

Recommended Posts

Hello

 

I can install the game from CDs and run it just fine (aside from the missing sound effects, but I'll figure that out after). However, I have been completely unsuccessful in installing the 1.3 patch.

The installer runs and it does install new files in the game directory, but whenever I run the game it still shows 1.0 in the bottom-right corner and also the Custom button doesn't appear (for the widescreen fix).

 

I've tried downloading the 1.3 installer from multiple sites, running it as administrator, running with Win XP compatibility, running it from the NOLF 2 game directory, even running it in Safe Mode. No matter what I do I can't get the game properly patched.

 

I've tried reinstalling the game and tried launching it with every combination of administrator and compatibility that I could think of. I'm also installed to the default directory (C:\Program Files (x86)\Fox\No One Lives Forever 2).

 

I've also got the .rez and registry fix from this site and tried that as well, but it didn't seem to make a difference. Are those registry settings correct for Windows 7?

 

Also, I figured I'd try installing lower patches first. I managed to find the v1.1 update from a website somewhere and that one actually worked (at least, the number in the menu changed to 1.1). However, I couldn't find the 1.2 patch anywhere and the 1.3 patch still wouldn't work after going to 1.1.

 

I've tried adding no-cd patches and the server launcher in case it was just an .exe problem, but those don't work. I'm pretty sure it's because of the update just not quite working.

 

Does anyone have any ideas?

Share this post


Link to post
Share on other sites

NOLF 2 didn't have a 1.1 patch that I am aware of.

 

NOLF 1 however did.

Share this post


Link to post
Share on other sites

Thanks for the quick response.

 

Yep, it turns out they did:

http://www.neowin.net/news/no-one-lives-forever-2-retail-patch-v11

 

And here's where I downloaded it from:

http://www.pcgames.de/No-One-Lives-Forever-2-Agentin-in-geheimer-Mission-PC-16766/Downloads/No-One-Lives-Forever-2-v11-e-84610/

 

In any case, it doesn't seem to help me get to v1.3 which is my main goal.

 

I noticed in this post a user mentions needing to modify the registry patch "for Win 7 locations":

http://unityhq.net/forums/index.php?showtopic=2495&p=98426

 

He must be referring to the Nolf2regfiles.reg downloadable from this site. Does anyone know what these modifications might be? From looking at the contents of that file, I can see that it adds registry entries to

HKEY_LOCAL_MACHINE\SOFTWARE\Monolith Productions\No One Lives Forever 2\1.0

 

I didn't have those entries before applying that .reg file, but they don't seem to make any difference for me. Is there some other location that these registry entries should be made?

 

Thanks

-Devan

Edited by Devan

Share this post


Link to post
Share on other sites

That should be the path if you installed to the default directory.

Share this post


Link to post
Share on other sites

 

I'm having the same problem with XP. :(

 

Why are you using XP still?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this