Jump to content

Help please with widescreen and general running


Recommended Posts

I'm having a variety of issues getting this game running.

If I use the version on this website or the revive version I can get the game to launch. However when I change to widescreen resolutions the menus get cut off with the back and exit off the bottom of the screen. This is with the plus version which both say they have a widescreen patch integrated.

I remember having this problem years ago so I tried adding the modernizer patch. This fixes the menu issue and allows me widescreen which appears correct. The game will launch and looks fine, apart from the "are you sure you wish to quit" "yes" option extending outside the box.

However this option means I can't launch the game subsequently, it just goes to a white screen and returns to desktop. There is a box with the message "crash detected. SE at address 0X00650E3A inside E:\Games\No One Lives Forever 2\lithtech.exe loaded at base address 0x00400000 Please check debug.log for more information.
I have to change the display in the launcher to get it to launch then change the resolution in game again.

I had a look through the forums and they mention changing dgvoodoo settings. However the version I downloaded from this website does not have dgvoodoo with it despite it saying it does. If I add dgvoodoo the game no longer launches with the error "Error in CGlobalClientMgr::Init() Error: 817021039:0 d3d8.dll
I've tried using dgvoodoo with both the revive and the version on this website with the same result.

This occurs if I use the version on this website or the one direct from dege's website.

I'm a bit confused as I haven't found any references to other people having problems with the widescreen patch of either version so I'm not sure what I am doing wrong.

I am running Windows 11 up to date as of 1/1/23. Nvidia Geforce RXT 4090 driver version 527.56, On Intel Core i9-10920X 3.5GhZ, 64GB Ram. Screen resolution 3840x2160 at 120hz

If you have any suggestions they would be greatly appreciated.

Link to comment
Share on other sites

Welcome to UHQ. 

 

I'd start with this version of dgvoodoo. 

I assume you have set Windows Compatibility mode to Windows XP SP2 before launching the game? 

Link to comment
Share on other sites

Hi, thank you for the welcome and the reply.

I have now tried with the compatibility mode set to Win XP SP2 in both the lithtech and NOLF2 exes and with the version of dgvoodoo you linked to but I still get the same error about d3d8.
I have found I can get the game to run, in menu correct widescreen using the modernizer but limiting the resolution to 1920x1080. This allows me to relaunch the game without any problems. Pushing the resolution up to 4K prevents it from launching on the subsequent attempts without first setting a different resolution in the launcher.
I can live with this setup but I do find it intriguing I have had so much trouble and others haven't with both the native widescreen support and now with dgvoodoo.
It made me think of another question, what is the difference between the revival version on the tk website, 1.3 version on this website and the modernizer? Will I be losing anything running the modernizer instead of the plus version (from this site)?

And I have wondered why the revive web page (http://nolfrevival.tk/) and this website seem disconnected. One doesn't seem to reference the other, no link to this forum on revival and no link to that website on the downloads section here. And pcgamingwiki doesn't even mention the tk website.

 

Thanks again for the reply.

Link to comment
Share on other sites

Given the games age running it in 1920x1080 isn't unreasonable. 

What video card are you running on your computer? 

To answer your "disconnect" question, I'm not sure who started the revival site a couple years ago. They have never reached out to us. 

We've been around since 2003. 

 

Link to comment
Share on other sites

Yeah I'm happy with that resolution and the game seems fine that way.
My graphics card is a MSI GeForce RTX 4090 Gaming X Trio.

I am glad there is still an active community and a place to get advice about these games, thank you for all your help.

 

Link to comment
Share on other sites

1 hour ago, cloister56 said:

Yeah I'm happy with that resolution and the game seems fine that way.
My graphics card is a MSI GeForce RTX 4090 Gaming X Trio.

I am glad there is still an active community and a place to get advice about these games, thank you for all your help.

 

Nice card.

I have an ASUS ROC RTX 3080. I fired up my NOLF2 tonight to see what I have it set to.  It runs on my Windows 11 Intel Core9 computer with the before mentioned card with these settings. If I try to ramp up the resolution it becomes unstable as well. 

image.png

Link to comment
Share on other sites

  • 3 weeks later...

Since you're able to run the 1.3 version of the game, but not modernizer it sounds like you're missing some dependencies. Modernizer was compiled using visual studio 2019, so you'll need to have Visual C++ Redistributable for Visual Studio 2015 or newer installed.

https://www.microsoft.com/en-us/download/details.aspx?id=48145

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines Privacy Policy.