Jump to content

Problem with NOLFTOOLS001.REZ and CSHELL.DLL


Recommended Posts

Hi everyone,

I joined Unity HQ not long ago, and was so happy to discover NOLF ! I finished the 3 games of the series, and now I want to mod the games. That's where the unexpected turbulence occurs (wink, wink).

 

From DEdit with love

--> I found out while using DEdit for NOLF 1, that I can access the textures and models folders ONLY with DEdit through the "Open Project" action when I browse the folders. I mean, they are available to use in DEdit itself, when creating my level I can select them, but I can't find the folders anywhere on my hard drive, it's problematic because I'd love to use the textures of NOLF 1 for modding NOLF 2. I only had those files extracted, see What the bug.PNG

-> So I used the unrez.bat again to extract the resources from NOLFTOOLS001.REZ again, and I found out that there is an error message at beggining of the console action, see Console Error.PNG

--> Of course, I checked and there is enough space on my hard drive (8GB available).

--> So I tried reinstalling the game, thinking there might have been a problem during the extraction of the folders or something like that. But, nope, nothing changed. Therefore, indomitable like Cate Archer and full of inspiration, I thought the problem might lie in the file itself so I rushed to download WinRez and pry it open with a loaded Bacalov Corrector directed at its forehead (oops, I'm forgetting that right now I'm writing a forum topic and not a fanfiction).

--> Bingo, I managed to sneak in the safe's room, got poisoned by lasers and started seeing and hearing goats (ah? yeah, right, i'm still on the forum, not in the game) I think the file is the problem. Indeed, it contains only the files that got extracted, see WinRez Content.PNG

--> (so that's maybe why there was the error message in the console, because it couldn't find all the files supposed to be here)

--> That's why I'm calling out to you, hoping someone would know if something is possible or not about this issue, I thought maybe someone could upload the complete NOLFTOOLS001.REZ file? I don't know how to access the textures otherwise, I tried to browse it in my entire PC and to show hidden files in every NOLF folders, but nothing. (I'm frustrated, because I saw at the end of the NOLF 2 mod The Return Of HARM that they used the HARM's green and yellow crates textures, and it looked pretty cool)

 

CShells on this evening's menu

--> Second problem, that might be directly related to the first one : I thought I might use NOLF 1 DEdit anyway, and tried to run a world. I did everything from the tutorials, including setting running paths, processing the world, I even tried with one of the world samples, BUT when I click on Run, THIS appears, see Fack Ju Goethe.PNG

--> Thinking there might be something in the world processor, see Processing Options.PNG I tried adding the Project Directory path, but nothing changed.

--> I also tried putting the CSHELL.DLL in almost every NOLF folder, but nothing changed. I saw on the forums that lots of people got problem with the CSHELL.DLL to run NOLF, but I never had and I still don't have any problem to run NOLF itself.

 

--> Moreover, I dont' have any of those problems with NOLF 2 DEdit, I have folders for textures and everything else, and I can perfectly run worlds with NOLF 2 DEdit, no problem with CSHELL.DLL

I thank you in advance for your attention and I apologise for this long novel !

 

What the bug.PNG

Console Error.PNG

WinRez Content.PNG

Fack Ju Goethe.PNG

Processing Options.PNG

Link to comment
Share on other sites
 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
  • Create New...

Important Information

By using this site, you agree to our Guidelines Privacy Policy.