Jump to content

NOLF1 mostly fails to launch on Windows 10?

Recommended Posts

I've tried downloading the latest versions of NOLF 1 and 2 from this site, "nolfrevival.tz", and "gamesnostalgia.com" - but can't get NOLF1 to work most of the time on my Windows 10 system, even though occassionally I can get it to work (maybe 1 out of a hundred tries) before it never works again.  (NOLF2 works fine, with no particular issues at all).  The launcher always works o.k. and allows me to set my native screen resolution.  I've run it through all the Windows compatibility settings (trying to run it as if under XP, Win-98, etc.), tried setting the executables to run as administrator, and even re-booted my system to make sure nothing is hanging around in the background - but still can't get the game to work virtually all of the time. 

On the rare occassions where I do a fresh install and diddle things enough to randomly get it to actually get past the launcher (which is not a given, many times it simply won't work even after a new, fresh install), I can play forever - until I eventually save and exit the game.  After that trying to re-start it again (from the launcher) puts up a very small, blank screen window for anywhere from a few seconds to "forever" and the game never takes off - ever.

I'm rather baffled by the inconsistency of how NOLF1 can occassionally be made to work correctly "once", but then will never function correctly after that until a new install is done - aren't computers supposed to be deterministic?

My Win-10 Pro system (latest maintenance and AMD video drivers) has a 6 core (12 thread) i7-5820k processor, 32GB of memory, an RX-480 (8GB model), and a 1920x1080 screen resolution.  No issues running any of the other hundreds of games I have off Steam, Epic, Origin, or GOG.

After buring physical copies of the CD's, I tried to run the setup program from them - but it kept dropping out thinking the game was already installed (even after I'd erased the containing directory), presumably because of something it saw in the registry?  I never see NOLF show up in the Windows "Programs and Features" menu, so can't delete it from there to clean up the registry either.  So far I have not tried manually changing (to what?) any of the NOLF registry entries or deleting its registry entries entirely.  

Has anyone seen similar behavior with NOLF1 pretty much not running under Windows 10 and have any thoughts or suggestions as to how I may be able to get it working consistently?  Thanks for any help you can provide!    

Link to comment
Share on other sites

The original NOLF won't run on Windows 10 well if at all. 

The GOTY version of NOLF runs on Windows 10. 

Link to comment
Share on other sites
Posted (edited)

1. Install GOTY version of NOLF  here(magnet-link)

2. Install MODERNIZER for  NOLF (Nolf_PACK_02)  here



Edited by orion98
  • Like 1
Link to comment
Share on other sites
  • 2 months later...

I've always had intermittent problems with Nolf 1 on Windows 10, so in the end dgVoodoo was the best solution and now it runs perfectly.


However, if you're running an AMD card you'll need to select the output to D3D12 in the dgVoodoo control panel. I also set the FPS limiter in-game (with Moderniser patch) to 60 and this fixed the cutscenes audio cut-offs.


This is the GOTY version by the way.

Edited by ElGringo
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Guidelines Privacy Policy.