Sign in to follow this  
-eGo- ItsMe

The NOLF 1 Launcher Issue

Recommended Posts

I was wondering if anyone knows who the creator of the launcher is and could pass along some minor issues for me (if the creator doesnt see this thread anyway :P )

 

There is no custom button on the new launcher... Dunno if it is the same for you NOLF2ers but the custom button is to load your custom rez files in to the game. At the moment I have to run the old exe and change the REZ riles when I want to and then run the game. At the moment that isnt a problem but when the master goes down it will be kinda annoying having to load up the game then quit then launch with the launcher.

 

Also something else I noticed is that if you use the launcher and just press play (without choosing a server) to get to the main menu then my version is reverted to 1.003 but if I join the unityHQ server through the launcher my version stays at 1.004. No idea why that happens maybe something the modder can look in to.

 

None of this is game breaking but just a bit of input from a native NOLF1er :P

 

I had a play around with the launcher and may make a quick tutorial at some point for the new players that might just happen to want to play nolf :P

 

Greetz,

|eGo|ItsMe

Share this post


Link to post
Share on other sites

The Custom button should show up if there is a custom folder in the game's root directory. NOLF2 & CJ handle custom .rez files differently from NOLF in 2 groups, resources (maps that are auto loaded first) & mods (selected from custom menu, loaded last).

 

The version reverting seems odd... the launcher loads the updates from the Registry string Update Command Line, unless I'm missing something...

Can you post the contents of your launchcmds.txt when the game loads up to 1.004 and again as 1.003?

Share this post


Link to post
Share on other sites

Sry it took a while to respond been a bit busy lately :P

 

However, I dont have a launchcmds.txt file at all and I do have a custom folder but I still dont get the custom button on the Launcher :(

 

Also I realised when I launch the game through your launcher my map packs are not loaded either :S

Share this post


Link to post
Share on other sites

Is NOLF installed in C:\Program Files? If so, are you running as admin?

Share this post


Link to post
Share on other sites

Is NOLF installed in C:\Program Files? If so, are you running as admin?

NOLF GOTY installs there the regular one will try to install to C:\Program Files (x86) on a 64 bit system.

Share this post


Link to post
Share on other sites

Is NOLF installed in C:\Program Files? If so, are you running as admin?

 

I have the goty version but it still installed to C:\Program Files\Fox

(not x86)

 

I dont normally run as admin but just tried but still no custom button :(

Share this post


Link to post
Share on other sites

 

I have the goty version but it still installed to C:\Program Files\Fox

(not x86)

 

I dont normally run as admin but just tried but still no custom button :(

If you are running it on Windows 7 and especially 8 I'd try running it by right-clicking it and selecting the run as administrator. Other option would be to use Windows compatibility mode.

Share this post


Link to post
Share on other sites

Some of the launchers don't have a Custom-Button.

 

For example, I have the German GOTY version on 2 CD's. That launcher has no Custom button, no matter what I do - I can create the folder and I can add .rez files in the registry (the launcher command gets saved there), but no button.

 

I ended up getting a cracked executable from somewhere on the internet. The game still works, with the button. I don't know why they decided to remove that feature for certain languages.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this