Jump to content

Flickering in NOLF and other old games on Nvidia (very strange problem)


vorob
 Share

Recommended Posts

Hello, I’ve got a very strange issue with several old games, and I'm trying to find a solution. I’m sitting on laptop, Lenovo Y580, packed with i7 quad core cpu and Nvidia Optimus system (intel hd 4000 + nvidia 660m). It’s all working on Windows 7 x64 (all latest updates). All drivers are fresh and Nvidia driver is 332.21.


My problem is that in some old games (direct x 6 and 7 era) 2d elements flicker horribly, i'm talking about interface, menus and so on. 3d is ok. And that’s all only on Nvidia.


I saw this problem in several different games:


Rainbow Six (1998)

No One Lives Forever (2000)

Blood 2 (1998)

Gabriel Knight 3 (1999)


I've got a friend with the same laptop, the only different thing is that he has Windows 8 installed, no flickering. Same driver for nvidia. Then he installed Windows 7 and flickering is here.

I also have another friend with Nvidia Optimus laptop from another vendor and he is on Windows 7, he has flickering.


Aaaand i also found this guy in the interent with the same exact problem: https://forums.geforce.com/default/topic/626974/pc-components/630m-flickering-2d-elements-and-fmvs/


So, i’m trying to understand what unites games mentioned above? (directx 6-7 i suppose?)

And what has changed in Windows 8, so flickering is gone?


p.s. I was able to launch NOLF and Blood 2 in window mode, flickering was gone, other games don’t have windowed mode.

p.s. i’m Russian, sorry for my English.

p.s. on intel video card with latest drivers i've got horrible 3d artifacts, but if i revert to an older one all is ok, and that's a solution for now, but i can't see a thing underwater :)

Link to comment
Share on other sites

Try updating to the latest graphics driver from Nvidia. If you have a notebook you maybe have to patch the latest Mobility driver to work with your model.

 

Windows 8 ships newer versions by default, that could fix your problem.

Link to comment
Share on other sites

Try updating to the latest graphics driver from Nvidia. If you have a notebook you maybe have to patch the latest Mobility driver to work with your model.

 

Windows 8 ships newer versions by default, that could fix your problem.

 

Like i said in first post, my drivers are fresh. And there is no need to patch them nowdays, it was true few years ago, now all drivers are released simultaneously.

 

Its more likely they've changes smth in rendering in windows 8.

Link to comment
Share on other sites

 

And there is no need to patch them nowdays, it was true few years ago

 

Yeah? Well, tell that to manufacturers like Sony, where it's still not working nowadays. Nvidia even mentions this on their website ;)

 

You could also try 3D Analyzer from the Downloads section and fiddle with the options (like disabling Hardware TnL).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines Privacy Policy.