schmatzler

Unplayable on Windows 8.1

Recommended Posts

I'm trying to get the old NOLF1 running on Windows 8.1 for hours now and I can't find a solution to do so.

 

I have a lot of problems that did not occur on Windows 7:

 

1. The mouse is jerky and jumps all the time - it is not possible to aim correctly. I tried enabling and disabling the hardware cursor and disabled the pointer precision in the settings - no success.

 

2. Every time I start the game, I have to go to the display tab and manually pick a resolution - otherwise it would start up but it seems it runs without 3D acceleration - unplayable.

 

3. Nolf doesn't respect the settings anymore I enter in the launcher. For example, on Windows 7 I entered the following command to set the resolution and screen depth:

-rez nolfdll.rez ++screenwidth "1360" ++screenheight "768" ++screendepth "32"

The resolution is still working (if I go to the display tab first and pick any resolution there), but the depth not. It always runs in 16bit graphics, which is horrible. :(

 

and 4. it crashes from time to time while loading levels. Compatibility mode doesn't fix it.

 

Am I the only one that has these serious issues on Windows 8.1? What can I do?

 

It really frustates me - I know that a lot of you are playing on my hirnschwund.net server and now I can't join you anymore :( Shouldn't have upgraded to this mother*** Windows 8.1 - they must've really messed something up with DirectX on that one.

Edited by schmatzler

Share this post


Link to post
Share on other sites

Compatability mode and disabling the hardware acceleration has worked for some.

Share this post


Link to post
Share on other sites

Hey schmatzler,

 

I have exactly the same problem with the mouse, and i spent hours trying to make it work. Unfortunately, it wasn't successful, but maybe some of your problems can be solved.

 

 

1. The mouse is jerky and jumps all the time - it is not possible to aim correctly. I tried enabling and disabling the hardware cursor and disabled the pointer precision in the settings - no success.

 

I have the same problems with my mouse. It jumps all the time, and I don't know why. This is what I've tried so far to make it work:

- Disable hardware cursor ingame, and turning mouse smoothing on and off

- Disable mouse acceleration in Windows mouse settings

- Force the game to run windowed by adding +windowed 1 in the command line (this is also useful because of the low performance of the game in fullscreen using Windows 8.1, windowed, the game is running in full speed with 60+ frames)

- Various compatibility modes, including Windows 95, 98/Me, XP, running the Game as administrator and turning off the High DPI scaling (both on NOLF.exe and lithtech.exe)

- Tried to fix the mouse with the fix for mice provided by Microsoft here: http://support.microsoft.com/kb/2908279 (I patched Windows and changed the Registry)

- Changing settings in the autoexec.cfg: "MouseSensitivity" and "inputrate" -- this is probably the most interesting part. Setting "inputrate" to a very high number, like "10000", makes the mouse movement fluid, but since the mouse continues to move for a while, the game is still unplayable.

- Forced VSync and capped framerates using a tool for my NVidia graphics card.

- Running the game in virtual machines, using VirtualBox and VMware: VirtualBox doesn't support DX7 Games, it wasn't working, and VMware does launch the game, but has difficulties with menu screens. The Background and/or the text is missing, and the screen goes black while you have to chose an option during a dialogue. I tried running the game on Windows 98 and XP in VMware.

 

Well that's about it, I don't know what else to do ;-) Maybe, if someone has Windows 7 on VMware, we should try running the game on it, since VMware has different graphics emulation drivers for Vista and 7 or something...

 

 

2. Every time I start the game, I have to go to the display tab and manually pick a resolution - otherwise it would start up but it seems it runs without 3D acceleration - unplayable.

 

Not sure, but this may be due to restrictive settings in Windows 8. Did you install the game in the "Program Files" folder? If yes, try disabling the write protection from the autoexec.cfg file in your game directory. Maybe, installing the game somewhere else (i have a specific "Game" folder) might solve this.

 

 

3. Nolf doesn't respect the settings anymore I enter in the launcher.

 

I had the same problem, and I solved it by disabling the compatibility mode of NOLF.exe (this is the program you open by using the shortcut of the game). Just turn off the compatibility mode of the shortcut and it may work again. I think this does not affect the compatibility mode of the main game, because NOLF.exe is just the launcher, and lithtech.exe is the game itself.

 

 

4. it crashes from time to time while loading levels. Compatibility mode doesn't fix it.

 

If you changed the compatibility modes of the launcher, try changing them on lithtech.exe in the game folder. I haven't played the game long enough (kinda hard without mouse), but it never crashed on me so far all the times i tried to load it.

 

Well I hope I could help a bit, if somebody finds out something new, let us know :-

Edited by Instandhaltungsnachweis

Share this post


Link to post
Share on other sites

Virtualization is a good idea, I thought that too and installed VMWare and VirtualBox. Sadly, the 3d emulation from both of them is not good enough to run NOLF at a reasonable speed. It's playing like "back in the days" on a 233Mhz Pentium II :P

 

Also, in VMWare the screen is flickering when starting the game. It looks like a stroboscope which ruins the whole experience and drives you mad.

 

I have co-installed Windows XP now alongside Windows 8.1 - NOLF is running fine now. In widescreen and 32bit, without mouse jerkiness.

 

It's a bad situation because from now on the NOLF1 players will decrease when everyone is switching to the latest windows version :(

Share this post


Link to post
Share on other sites

I found out something strange lately: I have a notebook with an Intel Graphics Card and an additional NVidia Card. I forced the game to run on my Nvidia Card, because the game has lots of glitches running on the Intel Card. Just for fun, I tried to force the game to run on my Intel Card, and I found out that the mouse doesn't jump anymore. It stops from time to time, but it's much more playable than before. Now I'm very confused, because the mouse issue seems to have something to do with the graphics card... O_O Maybe we use similar computers, because most people seem to play the game on Windows 8.1 without issues...

Share this post


Link to post
Share on other sites

I found out something strange lately: I have a notebook with an Intel Graphics Card and an additional NVidia Card. I forced the game to run on my Nvidia Card, because the game has lots of glitches running on the Intel Card. Just for fun, I tried to force the game to run on my Intel Card, and I found out that the mouse doesn't jump anymore. It stops from time to time, but it's much more playable than before. Now I'm very confused, because the mouse issue seems to have something to do with the graphics card... O_O Maybe we use similar computers, because most people seem to play the game on Windows 8.1 without issues...

 

Sounds about right with Nivida and AMD drivers the framerate caps at 30 FPS on Win 8.1. Some have corrects their issues by running it on compatibility mode for Windows XP

Share this post


Link to post
Share on other sites

Try playing the game in a window. For me it performed much better! At 60fps! But it ran twice the speed... So still unplayable.
I was wondering if this occurs in other configurations as well.

Share this post


Link to post
Share on other sites

I already played the game in a window, but unfortunately, this did not solve the problem. Other than this, you are right, the game performs much better, and on my computer, it runs on normal speed ;-)

Share this post


Link to post
Share on other sites

EDIT 2:

 

Fix for Mouse Stutter & Framerate

Even better! I've packaged both compatibility settings into a shim using the Microsoft Application Compatibility Manager. Download this zip, follow the instructions in the README file, and you'll be all set.

https://db.tt/WgrPi5iL

 

 

 

Original Post:

 

Found a fix for the mouse stutter!

 

http://support.microsoft.com/kb/2908279

 

Make sure you have applied all outstanding patches for Windows 8.1, then scroll down to the bit about the registry. If yours is anything like mine, you'll already have a compatibility flag listed in the entry, simply append a space and add "NoDTToDITMouseBatch" as explained in the article (don't overwrite the existing value).

 

As it says, back up your registry first - nasty things can always happen with regedit.

 

EDIT: I was also able to fix the framerate in fullscreen using the instructions here:

 

http://www.blitzbasic.com/Community/posts.php?topic=99477

 

Scroll down to where it talks about the MS Application Compatibility Toolkit and follow the instructions for lithtech.exe. I'm looking into ways to deploy this fix without the toolkit for others in the future.

Edited by Airslide
  • Like 1

Share this post


Link to post
Share on other sites

EDIT 2:

 

Fix for Mouse Stutter & Framerate

Even better! I've packaged both compatibility settings into a shim using the Microsoft Application Compatibility Manager. Download this zip, follow the instructions in the README file, and you'll be all set.

https://db.tt/WgrPi5iL

 

 

 

Original Post:

 

Found a fix for the mouse stutter!

 

http://support.microsoft.com/kb/2908279

 

Make sure you have applied all outstanding patches for Windows 8.1, then scroll down to the bit about the registry. If yours is anything like mine, you'll already have a compatibility flag listed in the entry, simply append a space and add "NoDTToDITMouseBatch" as explained in the article (don't overwrite the existing value).

 

As it says, back up your registry first - nasty things can always happen with regedit.

 

EDIT: I was also able to fix the framerate in fullscreen using the instructions here:

 

http://www.blitzbasic.com/Community/posts.php?topic=99477

 

Scroll down to where it talks about the MS Application Compatibility Toolkit and follow the instructions for lithtech.exe. I'm looking into ways to deploy this fix without the toolkit for others in the future.

 

Nice job.

I've uploaded it HERE on Unityhq as well

Share this post


Link to post
Share on other sites

I have Windows 8.1 and the only problem I have running NOLF Game of the year edition is I can't play mutiplayer. Can someone help me fix this problem. I bought this game when it first came out and loved playing online with other players from all over the world. Recently got the Game of the year edition and when I try to join a game online it goes to the loading page then goes right back to the main menu. Please help me to figure out what is wrong so I can get back online playing this wonderful game! P.S. I am going to introduce my 12 and a half year old daughter to this game. I have told her that she can do anything and this game shows her that girls can be hero's to and not helpless victims... The game is actually older than she is but, I hope she will enjoy it as much as I have... Oh one more question I have forgoten how to use the scope on the sniper rifle, could someone please tell me how to do this. Thank you so much for your time and help, as well as letting me join your wonderful organization. Yours Slipstream6

Share this post


Link to post
Share on other sites

Are you trying URA's Multiplayer Launcher? The original multiplayer matching provided by Gamespy has been shutdown so you need to use the Multiplayer Launcher.

 

As far as the sniper scope goes, the scroll wheel on my mouse cycles through the various zoom levels of the scope.

Share this post


Link to post
Share on other sites

You can also use this

It fixed this problem with my Windows 8.1 ;)

Share this post


Link to post
Share on other sites

Thank you so much for this fix! Runs perfect now!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.