Sign in to follow this  
ACE

NOLF source code setup

Recommended Posts

Hello,

 

I have always wanted to work on a mod for NOLF; however, the legacy environment required to do so has always been an obstacle. I need some 2013 guidance on setting up the source code for development. This isn't 1999 or 2001 anymore. So there are challenges present that are not covered by monolith initial installation instructions.

 

I have in my possession visual studio 6, I.e., I have visual c++ 6.0 I have to port it to a newer machine and then update it to the right service pack and directx sdk. Does anyone out there know how I can update VC++ 6 in this day and age?

 

Thanks

  • Like 1

Share this post


Link to post
Share on other sites

Where exactly are you stuck ?

Edited by AllRed

Share this post


Link to post
Share on other sites

I need the service packs for visual c++ 6. It's really hard getting a hold of those in 2013. I also need the directx 8 SDK.

Share this post


Link to post
Share on other sites

I need the service packs for visual c++ 6. It's really hard getting a hold of those in 2013. I also need the directx 8 SDK.

http://www.microsoft.com/en-us/download/details.aspx?id=5721. This?

Share this post


Link to post
Share on other sites

Only service park 6 can be found there. Can anyone confirm if the source still compiles with service pack 6? service pack 4 is required by the nolf source. I'm not sure if there would be any problems with service pack 6.

Share this post


Link to post
Share on other sites

Only service park 6 can be found there. Can anyone confirm if the source still compiles with service pack 6? service pack 4 is required by the nolf source. I'm not sure if there would be any problems with service pack 6.

 

Check HERE too

Share this post


Link to post
Share on other sites

So does anyone know where I can get Visual C++ 6 service packs 4 and the DirectX 8 SDK ?

I've managed to get my VC6 on a newer machine since my last post.

 

The first link posted is no good anymore and the second link doesn't contain VC6 service packs.

Edited by ACE

Share this post


Link to post
Share on other sites

Ok, I was able to compile the game and play the game with the compiled binaries without a problem after using Service Pack 6 and the DirectX SDK (Didn't say 8)

It worked... which is great. The readme file indicates that service pack 3 and DirectX 8 SDK are required but like I said, I'm getting by with the newer updates.

 

I got what I needed from these links:

VS6 Service Pack 6

http://www.microsoft.com/en-us/download/details.aspx?id=9183

DirectX SDK

http://www.microsoft.com/en-us/download/details.aspx?id=10368

 

One caveat, during the installation of Service Pack 6, I ran the setup file and it failed because it couldn't find a setup file. I renamed the file, sp698ent.stf to acmsetup.stf which solved the problem as described here: http://www.vbforums.com/showthread.php?721925-Problem-installing-VB-6-0-Service-Pack-6-on-Win-7-32-Bit-Embedded-PC

 

Hope this helps anyone else, and thank you to everyone who offered help.

Edited by ACE

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this