Jump to content

NOLF 2 stalls at start.


dudalb
 Share

Recommended Posts

I have a weird problems with NOLF 2 on Windows 7 64 bit with a Nividi 650TI card.

It will not start;When I hit the exe button I see the Windows loading wheel the the wheel vanished and nothing happens. I brought up Task Manager and in Applicatations I saw that NOLF 2 was running but was stalled. No Error Message, no nothing. I killed the program, and then spent a half hour playing around with compatibility settings,Nothing seems to work.

I did a complete uninstall and reinstall, same result.

I even tried something I was reluctant to do...I downloaded the legally dubious edition of NOLF 2 on the nolfrevival site. Same exact thing.

Weird thing is that it ran fine before this happened.

I don't think it was a Securom problem because Securom is enabled on my Windows 7 version, and I tried a NO CD patch (not the one from this site) same result.

Not to mention the same result from the version on the revival site.

I found one guy on a forum who said he fixed the problem by a weird combination of letting the stalled version run, then changing the compatialbiy setting on the NOLF 2 and Lithtech settings,reclicking the NOLF exe  and for thim the game then ran. Not for me.

Hopefully someone can help.  if there was an error message I at  least would have a clue as to the problem, but no error message. The games just does not, does not loadeven reah the first Play screen.

 

BTW NOLF One runs fine with no problems.

 

Posting in this section because the tech hell section here seems to be pretty dormant.

 

Thanks in advance.

Edited by dudalb
Link to comment
Share on other sites

6 hours ago, orion98 said:

I fixed the problem. Turned out to be the now infamous Windows 7 Game  Explorer bug....which is impacting quite a few games since Microsoft removed the Games Explorer server a few weeks ago. Google it, it's a common problem. There is a fix involving a  registry edit. I did the edit which disable Games Explprer complely , and now NOLF2 runs fine.

Basically, the Games explorer tries to find the server, fails and goes  into a loop which prevents any of the games it "registered"  from loading and causes a 100% usage on your cpu. Thank you, Microsoft. IThe idea of a proglram that automaticaly collects informationa about your game sucks anyway, but if you turned off the server you should have disabled the Games Explorer in a Windows update. I don't rage against Microsoft like some people, but they messed up here.

Thanks for the help, though I don't think any  of the fixes in the lind you posted would have helped since I  have no graphic issues with the game.

 

But, yeah, the Lithtech engine was always piacky.  NOLF was the first Lithtech game that worked fairly well, and even it had problems. Blood 2 was a complete buggy mess when released.\

 

Link to comment
Share on other sites

Aha…

in 2019, if you are using Windows 7 there may be problems with installing and running the game. This problem is created by the Game Explorer program built into Windows 7.
In Windows 8/10, the Game Explorer program is deactivated, so there is no such problem.
How to disable "Game Explorer" for Windows 7
1. Lock “Game Explorer” through the Registry.
Download ARCHIVE BLOCK_GameExplorer.zip (40Kb), read help
This archive also contains a list of 2072 games that the “Game Explorer” controls.
http://www.mediafire.com/file/24e176643j9cj2r/BLOCK_GameExplorer.zip/file

2 Or Use the "Stop Game Explorer"
Stop_Game_Explorer_1_1.zip, read help
http://www.mediafire.com/file/2mrtxy4eo4pmi2g/Stop_Game_Explorer_1_1.zip/file
There are two versions of the program in the archive: for 64bit and for 32bit (i.e., x86).
The program "Stop Game Explorer" works with system files, so use this program at your own peril and risk.

Edited by orion98
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines Privacy Policy.