Sign in to follow this  
Loremaster

Lighting and particle system

Recommended Posts

Hello,

 

I have a severe problem running worlds constructed in DEdit. The Light objects don't shed light. The levels are dark, or, if ambient lighting is set, milky grey. I also included a fire. The fire particle system turned out like in the picture and also sheds no light. I figure, something is wrong with the renderer, though DEdit options use the same settings as the actual game, which runs fine.

 

Any suggestions what's wrong and how to fix that?

 

 

 

Bild2.jpg

 

Share this post


Link to post
Share on other sites

Maybe this will help, when you are ready to process your map, start the World Processor and set the ProjectPath (click the "..." button and browse for your dedit project file (TO2.DEP)).

Share this post


Link to post
Share on other sites

Hi,

 

thanks. It helps in so far that the Ambient is displayed correctly and no longer results in milky mud on the screen. Actual light objects, however, are still dark and the particle system still.... strange....

Share this post


Link to post
Share on other sites

Update: Software Rendering shows the same results. Mmmprh. Guess somethings wrong with the light already during compile. Don't like "Lighting took 0.00 seconds".

 

 

Lighting world
Ambient light (10.0, 10.0, 10.0)
Setting up world for lighting
Lighting data built in 0.00 seconds
Lighting polys : 36
Lighting nodes : 3
Number of polies in lighting: 36
Lighting BSP nodes: 32
Lighting BSP first null node: 3
Lighting BSP longest chain: 3
Lighting BSP Full Nodes: 7
Lighting BSP took 0.00 seconds to generate
Light table resolution: (3x2x3)
Lighting grid took 0.00 seconds to generate
Lighting grid size in memory: 0k
Lighting points took 0.00 seconds to generate
Vertex colors took 0.00 seconds to generate
Base lightmaps took 0.00 seconds to generate
Lightgroups took 0.00 seconds to generate
Lighting took 0.00 seconds

Share this post


Link to post
Share on other sites

select brushes in the aera that are to receive light

go properties tab look at "lighting" select lightmaps...that should light it up

 

is that a "SpecialFX" object?

 

i have same problem with some of these....

but theres enough objects in there for an alternitive...

also some "SpecialFX" dont not give off light...

you will have to add "light obejects" yourself...

Share this post


Link to post
Share on other sites

sorry i never used this "particle system object" ...looks like you have to set the path for texture you will use in texture name window

and maybe particleflags value = 2? i dont know ....

if you just want a smiple fire....

just add SpecialFX and try a bunch in the "FXName" window drop-down menu there....

Share this post


Link to post
Share on other sites

OMG - that fixed it. Thank you. Default setting for brushes is Gouraud? That certainly is not clever. The Particle stuff will be solved later. I'm starting to get the hang of it again, has been over ten years since I last touched a level editor.

 

Thank you both.

 

@Sgt Pepper: A pity that adress in your sig doesn't work.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this