Sign in to follow this  
filozof97

Game won't start with enabled sound

Recommended Posts

Hello;

 

After some time I installed NOLF 2 again. Patched it, installed fix, widescreen patch etc.

When I try to start the game, I always get "ILT SoundSys error". But, it won't show up if I turn off the sound - then, everything works just fine, but playing game with no sound is no fun at all.

So.. what should I do ?

The PC runs Windows 7 x64.

Share this post


Link to post
Share on other sites
11 hours ago, filozof97 said:

Hello;

 

After some time I installed NOLF 2 again. Patched it, installed fix, widescreen patch etc.

When I try to start the game, I always get "ILT SoundSys error". But, it won't show up if I turn off the sound - then, everything works just fine, but playing game with no sound is no fun at all.

So.. what should I do ?

The PC runs Windows 7 x64.

Can you post your PC specs?

Share this post


Link to post
Share on other sites

Lenovo z500

Intel I7 3632QM

Geforce GT 645M + integrated Intel graphic card (I tried starting game with both)

8 GB RAM

Windows 7 Home Premium  x64

Realtek sound card

 

I've tried installing audio drivers again, but nothing has changed. Also, installing game audio codec manually is impossible - it says that this version is imcompatibile with that Windows edition.

 

 

Share this post


Link to post
Share on other sites
19 hours ago, filozof97 said:

Lenovo z500

Intel I7 3632QM

Geforce GT 645M + integrated Intel graphic card (I tried starting game with both)

8 GB RAM

Windows 7 Home Premium  x64

Realtek sound card

 

I've tried installing audio drivers again, but nothing has changed. Also, installing game audio codec manually is impossible - it says that this version is imcompatibile with that Windows edition.

 

 

Please try this and this then when you run the game run it in Windows XP SP3 compatibility mode and as administrator.

Share this post


Link to post
Share on other sites

Also check that the hardware sound is disabled (use the software sound) 

From the Nolf2 launcher application, click on the "options" button and

then click on the box next to "Disable Hardware Sound".

Share this post


Link to post
Share on other sites

I've installed Nimo, but can not install wmfist.exe - when I click on it, nothing happens. I've extracted the archive by 7-zip and tried to install setup_wm.exe, but system bans it, saying that it's incompatibile. Probably, finding more modern version of that codec would help, but it seems that it doesn't exist/was replaced by something.

Share this post


Link to post
Share on other sites

Have you tried running the game in compatibility mode (Windows XP SP2 or SP3)?

Share this post


Link to post
Share on other sites
On 6/10/2019 at 3:08 AM, Eliteone said:

Also check that the hardware sound is disabled (use the software sound) 

From the Nolf2 launcher application, click on the "options" button and

then click on the box next to "Disable Hardware Sound".

I assume you did this then relaunched the game? 

Share this post


Link to post
Share on other sites

Have you tried getting the latest drivers from the Lenovo support site? 

 

 

Share this post


Link to post
Share on other sites

Not sure if this makes any difference but try to copy WMFADist.exe from Nolf2 disk 1 to C:\Windows\SysWOW64\ and reboot. Sounds like that sound codec is missing from your installation. You can also try to leave a copy of it inside the game folder.

I would also check if SndDrv.dll is missing from the game folder or if it may be corrupted. It should be 61 440 bytes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this