DukofDeth

Problem Running NOLF2 on Win7

Recommended Posts

From what I came across on the web, this is not really a new issue. However, the odd thing about my problem is that I had no trouble running either game - NOLF or NOLF2 - on my system [Dell Inspiron 530, ATI Radeon HD 2600 XT card, 32-bit system], yet that was when I had Win XP as the OS. I updated to Win7 last spring [2011], and now the dumb computer is trying to tell me I don't have either Direct X 8.1 [i've got better than that] or/nor do I have a video card with TnL. Yet if I lacked that, how is it the game ran fine when I was using XP? For NOLF, I'm getting either a "cannot configure D3D emulator" error or a "missing cshell.dll" error. ANd threse errors persist despite me reloading twice, and for the second install I made sure to shut down my iTunes and everything extraneous. Yet no change - the same errors. I even downloaded a new Catalyst package to ensure I had the updated drivers for my video card, but again, no such luck. Perhaps someone out there might have some advice for me. I would really like to introduce a friend to this game, but I'm not about to return to XP - where would I even get a copy?

 

Not even the patch available on this site was any help to me. And to add insult to injury, my wife's old "Fail Comp" - the old laptop she inherited from her folks when they got a much better one - is running NOLF fine, and it's got Win& on it, too! Seriously, I am at a loss as to what I must have lost in "upgrading" to Win7.

Edited by DukofDeth

Share this post


Link to post
Share on other sites

Some people have had to run it in XP compatibility mode. Right cick the nolf2 exe file and go to properties then compatibility tab to change it to XP SP3.

That solves the issue for quite a few people.

Share this post


Link to post
Share on other sites

As it turns out, most of my problem was probably my television - I was also trying to connect my PC ower to my flatscreen. I was able to do that, but neither NOLF nor NOLF2 responded to it. Once I reconnected my tower to my proper monitor, the games worked. NOLF works fine - no problems I can see. NOLF2 refuses to give me sound, or any subtitles, and not even the lip-syncing is working! ANd when I apply the v1.3 patch, NOLF2 won't fire up at all - I get the initial bit, where you can press the "play" buttom, or mess about with optional settings, but once you hit play... Nothing. It's the same on my wife's laptop. Now, I know NOLF2 ran fine on my system when it was fresh from Dell, running with Win Xp. Now I've got Win7, as does my wife's laptop, and now NOLF2 is messing up. Accoring to Windows, my video and audio drivers are up to date. Hence, either Windows is full of it [and it probably is] or Win7 has some featurew that is messing with the sound, either during the running, or during the install. Is it possible that "Windows Defender" is the culprit? That is a new feature - as much as I know, since I'd never heard of it till WIndows 7 [i've no idea if it was with Vista].

Share this post


Link to post
Share on other sites

Yeah. I've been having the same issues. Installed the game (my friend bought me for christmas :D ) and no sound. Characters lips don't even move. It's as if the dialogue just isn't recognized. I tried using the NOCD patch and now I'm getting the DLL cshell.dll nonsense whether I use XP compatibility mode or not. Windows 7 is complete rubbish. Any words of advice? Help a brotha out.

Share this post


Link to post
Share on other sites

After a fresh install of the main program, then reinstalling the patch, and running the Lithtech and NOLF2 exe files as Compatable for WinXP SerPk3, as well as as an Administrator, I did get the thing to work. I think the earlier confusion it had was due to me trying to plug my system into the television. That should have worked, as there's not a lot of difference between a monitor and a television now that theres so much interface hardware on them, and my computer did run on the TV, it just wouldn't run NOLF or NOLF2. Once I uninstalled and reinstalled, then reinstalled the patch, everything worked. Incidentally, the patch from this site [which you had to manually paste into the "Fox/No One Lives Forever 2" folder and then run a registry edit patch - that did not work. I can't remember where I got it, either - I was all over the place looking for solutions. It's so funny now how if you look carefully, you'll notice that every second forum remark Google pulls up is just an advert generated specifically to your search parameters. Be careful - I almost got suckered into a bunch of things. However, as much as I hate to say it, if WIndows says my drivers are up to date, then I would say they are. Yet those programs Google was trying to push on me - Windows Fixit, Registry Fixit... All of them claimed free solutions to my problem, but when it came time to deliver, my free solution was goign to cost me. So I lost a day cleaning all that shite from my system.

All I can say is just be patient. I'll see if I can find that patch again and post a link to it. Otherwise I could just e-mail it to you. I don't think the rules of the Internet would allow me to upload it, even if it is an official patch. Somewhere, someone got permission to post that patch.

Edited by DukofDeth

Share this post


Link to post
Share on other sites

If you are referring to the 1.3 retail patch the one I have posted here is the one the was officially released from Sierra/Monolith. The LivesForever mod needed to play multi-player post master server shutdown is a community mod and has to be placed in the mods folder manually.

 

Please let me know which patch specifically and I'll be glad to check it.

Share this post


Link to post
Share on other sites

Then that would explain why I couldn't get it to work for me - it was a mod, not a patch. I should have read the explanations better. To be honest, I was doing a lot of my searches late at night, and maybe a bit too frustrated to follow the advice I gave about being patient. But it is the official patch that got things up and running for me. And there is one site on the net - again, I can't recall which one - that had a corrupted patch 1.3 for NOLF2.

 

I just checked my search history, and I think "www.shacknews.com" had the corrupted file, and it was "games.softpedia.com" that had the working one. I never thought to check this site for a differnet patch, as I had mistaken the mod for a patch. Thus I would have to say there should not be any problems with any patch on this site if no one else has complained; the error was entirely with me. And with the way my router was acting up earlier in December, the corrupted patch may have gotten messed up in downloading, and may have been fine to begin with.

Share this post


Link to post
Share on other sites
Then that would explain why I couldn't get it to work for me - it was a mod, not a patch. I should have read the explanations better. To be honest, I was doing a lot of my searches late at night, and maybe a bit too frustrated to follow the advice I gave about being patient. But it is the official patch that got things up and running for me. And there is one site on the net - again, I can't recall which one - that had a corrupted patch 1.3 for NOLF2.

 

I just checked my search history, and I think "www.shacknews.com" had the corrupted file, and it was "games.softpedia.com" that had the working one. I never thought to check this site for a differnet patch, as I had mistaken the mod for a patch. Thus I would have to say there should not be any problems with any patch on this site if no one else has complained; the error was entirely with me. And with the way my router was acting up earlier in December, the corrupted patch may have gotten messed up in downloading, and may have been fine to begin with.

we have the 1.3 patch here too. No worries though and glad you got it sorted out.

Share this post


Link to post
Share on other sites

Just leaving a reply so I can download the 1.3 Retail Patch for the US version of NOLF 2. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.