Sign in to follow this  
skyh

NOLF Mouse Response Problem

Recommended Posts

Hi

 

I'm running NOLF GOTY edition under Windows 7, and am having problems with the mouse response.

 

After first installing, the mouse was awkward - jerky and oversensitive when using mouse-look to control movement, oversensitive when placing the target cursor to shoot, then barely showing any response at all when I tried to make fine movements to get the cursor over the target. I turned off cursor acceleration in Logitech Setpoint, but it didn't help.

 

I tried hardware cursor on and off, with no effect, several times. Eventually I turned it on again, and suddenly the mouse response was OK. I played for a few hours with no mouse problems, but when I started up again today, the response problems were back, and nothing seems to fix them. For small movements the mouse sensitivity is way, way too low; for large movements it is much too high.

 

I'm using a Logitech G700 gaming mouse.I played around with in-game sensitivity and smoothing settings, but they don't seem to help - there is no combination which works for both large and small movements. And as I mentioned, the problem has come and gone irrespective of the settings in my Logitech software, or in the game. I also don't have any mouse problems with other games.

 

Any suggestions?

 

Thanks,

skyh

Edited by skyh

Share this post


Link to post
Share on other sites

I forgot to mention some other weird behavior: when the mouse response was "good", I couldn't change the key and mouse button assignments in the control menu. Today that all works fine, but the mouse is a problem again. It seems as the game behavior is unstable.

Edited by skyh

Share this post


Link to post
Share on other sites

Have you tried running the game in compatability mode? (Windows XP SP3 for example)

Share this post


Link to post
Share on other sites

Have you tried running the game in compatability mode? (Windows XP SP3 for example)

Good idea - I'll try that!

Share this post


Link to post
Share on other sites

Have you tried running the game in compatability mode? (Windows XP SP3 for example)

I tried both Win XP and Win 98/Me compatibility (the latter with Visual themes disabled). Same problem with mouse, and after disabling the mouse cursor in Win 98 compatibility, I suddenly lost access to all display resolutions higher than 1280x960.

Share this post


Link to post
Share on other sites

Another observation - the problem seems worse when moving the mouse vertically.

Share this post


Link to post
Share on other sites

I tried using a Logitech MX510 mouse instead, and that works flawlessly - except that the extra buttons are not recognized.

 

My G700 buttons are all recognized by NOLF, but the mouse response is unplayable.

 

If I could just get NOLF to recognize all the MX510 buttons, I'd be set.

Share this post


Link to post
Share on other sites

I had some mouse sensitivity issues before (between normal and too slow), but enabling v-sync in my display drivers worked for me.

 

I have a MX610 lefty and SetPoint's key binding works most of the time, I have wheel tilt left & right set to 3 & 4 for weapon hotkeys and works in NOLF, NOLF2 & CJ.

Share this post


Link to post
Share on other sites

I have Windows 7. I tried vsync, triple buffering, turning mouse smoothing up all the way, and cranking up AA. What fixed it finally was in Control Panel, Mouse, Pointer Options, and turning off, (unchecking) "enhance pointer precision".

Share this post


Link to post
Share on other sites

i think i had the same problem with my mouse input in NOLF. slow movement of the mouse wouldn't even register in the game. and fast movement seemed very blocky like the DPI was turned way way down. this made it nearly impossible to aim with any precision. this is with windows 7 64bit, a logitech MX518 wired mouse, and logitech software version 8.50.

 

the solution i found was to go to the mouse control panel > pointer options > and disable "Enhance Pointer Precision". i think this feature is some kind of acceleration, but its effect on NOLF is that it gets the mouse DPI wrong when starting up. BTW, the logitech driver software also has the ability to disable acceleration per game (it's even also called "Enhance Pointer Precision"), but in this case it won't work--only the mouse control panel option works.

Share this post


Link to post
Share on other sites

Just to add to these solutions, I've found that old Lithtech games, from Shogo to NOLF1, don't like 16:10 or 16:9 resolutions - even if they are listed by the game - and on my PC mouse mouvement becomes jerkier in these aspect ratios, and with higher resolutions. 5:4 and 4:3 seem OK, and in 1024x768 mouse movement is fluid enough (although not 100% fine without other fixes as mentioned before). I'm playing the game windowed to avoid the loss of performance under Windows 8.1.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this