Sign in to follow this  
rehcraetak

hosting problem with private campaign coop server

Recommended Posts

hy, and hail to the nolf2 community, with all my respects for the job with the mods

 

i am a new member at this forum, but i used to play nolf and particularly nolf2 when it was brand new, and bought it in 2002, and i also used to play coop with a friend with a program called "modified server v1.0.1 beta "by dan", that seems to work like a charm in LAN, but i can't seem to make it work as an internet server, (it's a dedicated server).

 

back in time i made custom coopmission.txt files, that works fine today, but only in lan mode.

 

so my questions are the following :

- what must i tweak in config file(s) to make it "internet playable" (and by the way, in whitch config file(s)), BTW my server doesn't have a specific "internet killer name" :new_2gunsfiring_v1: , mine is just "no one lives forever coopératif" (yes...french...nobony's perfect i assume...), so where do i modify it, in config file(s) of course, (again, it's a dedicated server so i can't modify anything other than with these config file(s)...).

- i saw that the master server was down, so i use programs that i downloaded here for the clients PCs, as "lives forever" mod and "Join By IP" tool, works nice too, but i want to enter my server's IP adress and there is no way to do it, (or i didn't saw it...possible too...french i said...)

 

sorry for the maybe dumb questions, but i made these modifications a very long time ago, and i don't remember all i did a that time...

 

don't hesitate to ask questions if necessary, i'll try to answer my best.

 

thanks in advance

Share this post


Link to post
Share on other sites

To make it internet playable you would need to load the LivesForever mod as the master server for NOLF2 is no longer running. The mod is a workaround to that issue.

Share this post


Link to post
Share on other sites

ok, it's on the way to work fine !!!

 

i installed the "lives forever" mod on my server, and activated the mod in the custom menu, i launched the dedicated server, and...i finally see my server in the servers list But :

 

this is the exact synthax of what is displayed in the server list :

 

Name : **offline** NOLF2 Coopératif

Players : ?/?

Map : ???

Mode : ???

Mod : LivesForever

Ip : "my server's internet IP"

 

so as you see, first, the server is offline, and when i try to connect with my client, i get this : ""unable to join seleted game session""

 

AND

 

nothing is displayed in the details...

 

any ideas ?

Edited by rehcraetak

Share this post


Link to post
Share on other sites

The **offline** message means that the query failed.

Most likely due to the ports (27888 & 27889) not being open/forwarded.

You will need to setup port forwarding in your router for the Game Port (27888) & the Query Port (+1 of the Game Port).

Share this post


Link to post
Share on other sites

i've just looked at the ports in my router (Livebox2), and it's OK at this level, ports 27888/27889 are opened and good to go...but absolutely no change in the server list, (of course, i've restarted my dedicated server)...

Share this post


Link to post
Share on other sites

What are you using to connect to the server? game or one of the tools from our downloads section?

Share this post


Link to post
Share on other sites

on both PCs, i installed the followings :

 

- NOLF2_ExeMods_1.0.exe (that modifies/add new .exe in root folder of the game)

- LivesForever.rez mod (in "No one Lives Forever 2/Custom/Mods/LivesForever" folder)

- JoinByIp tool, (in the root folder of the game)

 

for my server :

 

- i launch the Nolf2srv.exe, and the "LivesForever" mod, that is activated via the "custom" section in the game launcher, when i launch it, the program ask me if i want to "host an internet server" and i accept by clicking OK

 

here is the main interface informations :

 

SERVER INFO :

 

- server name : Nolf 2 coopératif

- game type : cooperative

- running time : 07m:28s

- peak players : 0

- Total/Unique Players : 0/0

 

PLAYERS :

 

- Current Players 0/4

- Average Ping : 0

 

CONSOLE :

 

null

Disconnecting from host:

Initializing the server...

-- game.rez

-- game

-- game2.rez

-- gamedll.rez

-- Sound.rez

-- gamel.rez

-- gamep.rez

-- gamep2.rez

-- Custom\Mods\LivesForever\LivesForever.rez

Server initialized.

Server is running.

Connecting to host: SFI Clan

CServerMissionMgr::StartGame() setting difficulty to 0

CServerMissionMgr::StartGame() setting difficulty to 1

Loading world: Worlds\RetailSinglePlayer\c01s01

Loaded world: Worlds\RetailSinglePlayer\c01s01 in 1.11 seconds

Error loading model: FX\WATERFALL2.LTB 0 00 Invalid Header

Added 10 regions

DoRunWorld completed in 3.84 seconds

 

for the client :

 

- i launch the nolf2.exe, and the "LivesForever" mod, that is activated via the "custom" section in the game launcher, i see the server, but with the lines i wrote a few lines before, with ??? or **offline**...

 

 

that's all i have now, but if i can make a test or anything, let's go...

Edited by rehcraetak

Share this post


Link to post
Share on other sites

I do start the server NOLF2 with the mod LivesForever.rez

If I do not have a router, I have no FireWall, I do not have Antivirus then I do not see my server in the list of URA NOLF2_ExeMods_1.0.exe

If I have FireWall, Antivirus and router, and make forwarding BOTH (TCP + UDP) 27880-27900 ports on my router, then I can see my server on the list NOLF2 NOLF2_ExeMods_1.0.exe from URA

output

1. The router must have

2. To do port forwarding BOUTH (TCP + UDP) 27880-27900 on the router

So is there for NOLF2. lol

b6a3ca7aae9f.jpg

 

f0a89002502a.jpg

 

 

Edited by orion98

Share this post


Link to post
Share on other sites

ok, BUT :

- i have installed the right things (uh ?)

- i start the server as you do, with the "livesforever" mod, that's the only thing that seems right in the server's list.

- i have no firewall activated in windows (2008 server std SP1).

- i have switched off the router's firewall

- i have no antivirus in windows.

- the ports are forwarded correctly in my router.

- i have tested this server in 2 different PCs with the same results...(first PC with 2008 server sp1 std, and the second with Windows 7 X64 Home Premium sp2...).

 

as i said, i see my server, in the server list of my client PC, BUT it is **offline** and with no informations at all...

 

and

 

where can i change my server's name ?, where can i put a password ?, all these little things that i use to make years ago and that i have forgotten today...

Edited by rehcraetak

Share this post


Link to post
Share on other sites

You would change the servers name by modifying the text file (player.txt by default) you can also set the scmd password there too.

Share this post


Link to post
Share on other sites

Download and install a mod

LivesForever Plus

here

http://www.ifclan.at/dl_n2_momp.php

 

Play modes LivesForever Plus

Make settings on your server

Disconnect mode LivesForever Plus

Play modes LivesForever

Play NOLF2

 

Or

X:\Program Files\Fox\No One Lives Forever 2\Profiles

see Player.txt

..................................

[Multiplayer]

Dedicated = TRUE

MPRadar = TRUE

DMPlayerModel = 8

ScmdPassword = "*****"

AllowScmdCommands = TRUE

Guid = "*********************************"

Password = "password"

WeaponRestrictions = "Banana,BearTrap,"

PlayerName = "Player"

ClientPort = 27888

GearRestrictions = ""

AmmoRestrictions = ""

GameType = 2

LANOnly = FALSE

PlayerModel = 0

MaxPlayers = 4

Port = 27888

UsePassword = FALSE

MPDifficulty = 1

SkillAllowance = 10000

FriendlyFire = TRUE

MPPlayerDiffFactor = 0.100000f

BandwidthClient = 3

BandwidthServer = 5

BandwidthServerCustom = 10000

BandwidthClientCustom = 1024

PlayerSkills0 = 1

PlayerSkills1 = 1

PlayerSkills2 = 2

PlayerSkills3 = 2

PlayerSkills4 = 1

PlayerSkills5 = 2

PlayerSkills6 = 2

PlayerSkills7 = 1

PlayerSkills8 = -1

Edited by orion98

Share this post


Link to post
Share on other sites

ok, i have edited the player.txt file and now i have a "war name" for my coop server ;) (great !),

 

i have also compared my player .txt file with the orion98 one, and modified some settings as :

 

[Multiplayer]

LANOnly = TRUE => changed to FALSE

BandwidthServer = 3 => changed to 5

BandwidthServerCustom = 1500 => changed to 10000

 

[Cooperative]

MaxPlayers = 4 => changed to 8

SessionName = "Nolf 2 Coopératif" => changed to "Nolf 2 Coop rehcrA etaK"

 

the rest of the settings were OK, so no modification except the above

 

...and now...

 

settings have changed in the dedicated server's window, (normal), but no changes at all in the client's server list window...always **offline** and ???

 

i must have missed something but what ????

Edited by rehcraetak

Share this post


Link to post
Share on other sites

Open a port and port forwarding - it's not the same action

1. The router must have

2. To do port forwarding BOUTH (TCP + UDP) 27880-27900 on the router

Share this post


Link to post
Share on other sites

ok, i followed your instructions and re-made the port forwarding in my router => same bug...(**offline** & ???)

 

so i asked a friend (the other "nolfer"), to make a server from his home, (so with other hardware than at my home, he also made the port forwarding in his router) => exactly the same bug (**offline** & ???)

 

he has a windows XP home sp3 (x86), so i can tell today that the problem is not from the windows version...it's a start...

 

I want to know why this damn server doesn't want to work correctly !!!!

 

maybe from our game installation ?

 

in order :

 

- install from original CDs

- update 1.003

- mappack 1

- mappack 2 regfix

- mappack 2

- nocd 1.003 in root folder of the game (lithtech.exe and nolf2.exe)

- exemods 1.0

- copy of the LivesForever.rez in the right folder (No One Lives Forever 2/Custom/Mods/LivesForever/)

- copy of the join by IP tool in the root folder of the game.

 

- play ! and fail ! (for the server only, the clients seems to work perfectly and they can join public servers without any problems.

Edited by rehcraetak

Share this post


Link to post
Share on other sites

I had this problem for a long time.

I solved this problem by only buying a router ASUS RT-16 and port forwarding on the router.

As in Fig. shown above

 

And more:

Check if you see your server with Join_By_IP.exe?

To connect to your server needs to LAN

Share this post


Link to post
Share on other sites

How I host a Nolf2 Server:

 

- Install the game

- Patch the game to version 1.3

- Install LivesForeverPlus Mod and all UnityHQ Mappacks (+ additional Maps when you need them)

- Set "Nolf2.exe" and "Lithtech.exe" on "Compatibility Mode XP SP3" and "Run as Admin"

- Log in to my router (Netgear), set port 27888 and 27889 free on UPD and TCP (in case you can, combine the internal IP [ex: 192.168.1.3] of your server to the open ports)

- Start Nolf2.exe, set "LivesForever" (not LivesForeverPlus)

- In the main menu go to Multiplayer (LAN) -> configure your server (Port 27888 and Dedicated Yes!)

- Now, back in Windows set "LANOnly=FALSE"

- Join via the Nolf2 Multiplayer Launcher

 

Hint: Some routers deny you to join, in case the computer you use to join got the same external IP address (ex: 173.194.35.151[google.de]) as the server!!

 

PM me if you need live help via Skype for ex.!

Edited by {IF} Crusader

Share this post


Link to post
Share on other sites

ok, after a day break, i decided to try again with the router, so i have forwarded the 27888 & 27889 ports to the WAN ip of my server, (192.168.1.100), and again it is the same...i can see my server from the client window, BUT again, **offline**, and ???...

 

i've tried with a simple modem/router and conclusion :

 

When i test the 27888 & 27889 ports from a security website :

- with LIVEBOX2 : ports are closed (both)

- with modem router (ST510) : ports are opened and "stealth"

 

so here it is, the LIVEBOX have a nice problem with the opening of specified ports, that's confirmed by a search on google, and many people have the same problem with this model...

 

and in both cases, the same problem that i described before : **offline** and ??? (yes, with the ports that are opened and forwarded with the modem router also...)

 

just in case : the box's firewall is fully disabled and the port forwarding is configured as this, with a DMZ that is the server's IP (192.168.1.100)

 

image2cf365546a3599922218f9b87928c139a.jpg

Edited by rehcraetak

Share this post


Link to post
Share on other sites

Do you have a static IP address?

To create a server, you must have a static (not dynamic) IP address.

This is a paid service.

My provides service to a static IP address for $ 4 a month

Share this post


Link to post
Share on other sites

infortunately, it's not a static IP...and i'm not goin to suscribe to it as i don't know if it ll work...

 

i've got a last card solution...playing with my friend with something like Hamachi or some software like this, with a kind of VPN, but it doesn't work either...i mean, i can see my friend's directories, and files, in network neighborhood, and so him from the other side of the tunnel, but he can't see my nolf2 server even in lan mode...i'm starting to think that this is the last time we're going to have fun with this awesome game...

 

yesterday, we have tried these :

- hamachi

- wippien

- remobo (a "old hamachi" clone)

 

in all cases, we can see and access to each other PCs and directories, but nothing with Nolf2 server...we have tried all softwares in their last versions, so...i think we can close the No One Lives Forever book...

 

if you have any ideas to help us playing...feel free...

Edited by rehcraetak

Share this post


Link to post
Share on other sites

Are you running the Windows firewall on either machine?

Share this post


Link to post
Share on other sites

no firewalls, on both machines, and no firewalls on both modem/routers, i think we played this game with Hamachi years ago, with the same configs, so i don't understand as Hamachi would "make his way" through firewall and he is blocked nowadays...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this