Sign in to follow this  
ConnieFuse

NOLF 2 crashes on 'Configure Controls' in Options

Recommended Posts

Hi I really hope someone can help me. I'm trying to play the NOLF2 revival  on a laptop. I loved NOLF 1 after getting it working with your helpful links to DG Voodoo.

 I'm left-handed and have  severe arthritis in my hands so I REALLY need to reconfigure the controls from WASD to  arrow keys (Pls don't tell me to 'just get used to WASD'' as a lot of right-handed gamers do,that is not an option for me.) IDK  but why it crashes on  the controls to change keybinds.

I noticed when installing  a registry value to 'disable sticky keys 'appears. Disabling a file of the same name doesn't help.

I got NOLF to work using KeyTweaker, but it would not work with NOLF 2. I now do not have this enabled.

I need to change the keybinds, but it crashes every time I click on 'Configure Controls' in Options. I have no idea what to do.

I've reinstalled,run a registry cleaner, tried a few Widescreen patches. Nothing works.

 

My setup: Win 10, (64)GT 1060,(6GB),installed on D drive

https://www.msi.com/Laptop/GS63VR-6RF-Stealth-pro/specification

If anyone knows why this is happening or a fix I would be very appreciative. I get very depressed due to health issues and recently discovered NOLF 1 & 2 & love  this old IP so much as its humor cheers me up. Thanks.

 

Share this post


Link to post
Share on other sites

Are you trying to bind the game movement to other keys? If I am understanding correctly.

In the game click on Options then Controls. (Took the screenshot from the PDF of the game manual which we have in our downloads)

Options-menu.jpg

Controls: This is where you can customize your key mappings as well as adjust your settings for the keyboard, joystick, and mouse. Configure Controls: Key configurations are broken down into four sections. Click on Movement, Interaction, View, or Status to view the current key mappings. If you wish to change the key that a particular function is mapped to, 15 just click on the function you want to change and then press the key or button that you wish to use instead. If the key or button you choose is already in use by another function, then that function will become unassigned.

 

 

Share this post


Link to post
Share on other sites

The game  is fine when I click on 'Controls'.  It's the submenu AFTER that to configure keybinds. Excuse potato quality of pic, for some reason the game won't screenshot on my pc).If I click on the  'Configure Controls' it crashes to desktop immediately. So I can't even get to the key bindings.IDK what could be causing this. Thank you for replying- I wasn't optimistic anyone would be here!

nolfpic2.jpg

Share this post


Link to post
Share on other sites
42 minutes ago, ConnieFuse said:

The game  is fine when I click on 'Controls'.  It's the submenu AFTER that to configure keybinds. Excuse potato quality of pic, for some reason the game won't screenshot on my pc).If I click on the  'Configure Controls' it crashes to desktop immediately. So I can't even get to the key bindings.IDK what could be causing this. Thank you for replying- I wasn't optimistic anyone would be here!

nolfpic2.jpg

If you set the Windows 10 compatibility mode for the program to Windows XP SP2 does it allow you to click the Configure Controls? 

Share this post


Link to post
Share on other sites

The only option I have for Windows XP compatibility is Service Pack 3. It immediately crashes to this notice after I hit 'Play.'  Tried running it in other versions of Windows and while the game will load fine, it always crashes on the ' Configure Controls' command.

NOLF error.jpg

Share this post


Link to post
Share on other sites
9 hours ago, ConnieFuse said:

BTW, thanks again for taking the time to help me.

No problem.  Can you try the version of the game from our downloads? If yours came from another source it would make it a bit harder to figure out. 

 

Share this post


Link to post
Share on other sites
2 hours ago, Eliteone said:

No problem.  Can you try the version of the game from our downloads? If yours came from another source it would make it a bit harder to figure out. 

 

Alas I did use your file. That's what baffles me, as everything else from the download works super-well and the game runs great.(Your NOLF 1  file wouldn't let you change the controls either, (I understand that is a common NOLF bug on 64bit64 systems)but you could  at least get to the 'Change Control ' option- even if none of the changes stuck. I got around the problem by using a tool like Key Tweak to temporarily change default keyboard bindings on my laptop-easy to reverse & uninstall) but I un-installed  that when I thought it might be interfering with NOLF2.) I did notice there is a file called 'Disable Sticky Keys' and when it installs there's a registry value that says this.  Would this be a cause of the problem? !  Ran a reg cleaner in case Key Tweaker was still there but I really don't think it's the problem. Then I uninstalled and reinstalled the game but it didn't help. I am really baffled!

https://imgur.com/oKco3Jb

https://imgur.com/994nE7m

Share this post


Link to post
Share on other sites
6 hours ago, ConnieFuse said:

Alas I did use your file. That's what baffles me, as everything else from the download works super-well and the game runs great.(Your NOLF 1  file wouldn't let you change the controls either, (I understand that is a common NOLF bug on 64bit64 systems)but you could  at least get to the 'Change Control ' option- even if none of the changes stuck. I got around the problem by using a tool like Key Tweak to temporarily change default keyboard bindings on my laptop-easy to reverse & uninstall) but I un-installed  that when I thought it might be interfering with NOLF2.) I did notice there is a file called 'Disable Sticky Keys' and when it installs there's a registry value that says this.  Would this be a cause of the problem? !  Ran a reg cleaner in case Key Tweaker was still there but I really don't think it's the problem. Then I uninstalled and reinstalled the game but it didn't help. I am really baffled!

https://imgur.com/oKco3Jb

https://imgur.com/994nE7m

Not sure if you're open to a gaming keyboard. I use one similar to what I'm linking below and it allows the arrow keys near the number pad to work like the WASD keys. 

https://www.amazon.com/Redragon-S101-Keyboard-Ergonomic-Programmable/dp/B00NLZUM36/ref=sr_1_2_sspa?gclid=EAIaIQobChMInJrOsYGJ4gIVE_5kCh2P_A8EEAMYAiAAEgIPEvD_BwE&hvadid=323081842024&hvdev=c&hvlocphy=9033506&hvnetw=g&hvpos=1o2&hvqmt=b&hvrand=5504605832033680945&hvtargid=kwd-346295924576&hydadcr=24633_9648909&keywords=gaming+keyboard+razer&qid=1557218118&s=gateway&sr=8-2-spons&psc=1

Share this post


Link to post
Share on other sites

On NOLF1 did you download the GOTY version or the regular one? 

Share this post


Link to post
Share on other sites

I suspect that windows might prevent the game from editing configuration files on its own. I've experienced that to a certain degree myself when I don't run Nolf2.exe and Lithtech.exe as administrator in its properties.

If this isn't the issue, you could always edit the settings outside of the game:

Open your Nolf2 folder, then go to the profiles directory and unless you created a new one, the profile you wanna edit would be the one called  Player.

You should find a file called Player.txt there, open it in notepad

and scroll down until you find:

Quote

Forward = "##17@ @ "
Backward = "##31@ @ "
StrafeLeft = "##30@ @ "
StrafeRight = "##32@ @ "
Left = "##203@ @ "
Right = "##205@ @ "

Unless this differs depending on the keyboard, changing it to the lines below should let you control your character with arrows instead.

 

Quote

Forward = "##200@ @ "
Backward = "##208@ @ "
StrafeLeft = "##203@ @ "
StrafeRight = "##205@ @ "
Left = "##75@ @ "
Right = "##77@ @ "

 

Hope this helps :)

  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, Spawn said:

I suspect that windows might prevent the game from editing configuration files on its own. I've experienced that to a certain degree myself when I don't run Nolf2.exe and Lithtech.exe as administrator in its properties.

If this isn't the issue, you could always edit the settings outside of the game:

Open your Nolf2 folder, then go to the profiles directory and unless you created a new one, the profile you wanna edit would be the one called  Player.

You should find a file called Player.txt there, open it in notepad

and scroll down until you find:

Unless this differs depending on the keyboard, changing it to the lines below should let you control your character with arrows instead.

 

 

Hope this helps :)

Had mental pause. I forgot about this option lol

Share this post


Link to post
Share on other sites
On 5/7/2019 at 6:38 PM, Eliteone said:

On NOLF1 did you download the GOTY version or the regular one? 

GOTY version.

Share this post


Link to post
Share on other sites
12 hours ago, Spawn said:

I suspect that windows might prevent the game from editing configuration files on its own. I've experienced that to a certain degree myself when I don't run Nolf2.exe and Lithtech.exe as administrator in its properties.

If this isn't the issue, you could always edit the settings outside of the game:

Open your Nolf2 folder, then go to the profiles directory and unless you created a new one, the profile you wanna edit would be the one called  Player.

You should find a file called Player.txt there, open it in notepad

and scroll down until you find:

Unless this differs depending on the keyboard, changing it to the lines below should let you control your character with arrows instead.

 

 

Hope this helps :)

Editing this file might be THE way to go. I'll give it a try!(I did a similar ini edit of Murdered Soul Suspect as it didn't  have ANY custom keybinds) I'll report back when I've done it if it works. Thank you so much! This forum is the greatest !

Edit: Forgot to ask: what line would I need to write to bind 'Crouch' to Right Control?

Edited by ConnieFuse
left out quote

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites
5 hours ago, ConnieFuse said:

Editing this file might be THE way to go. I'll give it a try!(I did a similar ini edit of Murdered Soul Suspect as it didn't  have ANY custom keybinds) I'll report back when I've done it if it works. Thank you so much! This forum is the greatest !

Edit: Forgot to ask: what line would I need to write to bind 'Crouch' to Right Control?

Checking if you can run keybinding the normal way after running NOLF2.exe and Lithtech.exe as admin is the first thing I would test.

binding crouch to right control should be:

Duck = "##157@ @ "

 

Let us know how it goes :)

admin.jpg

Share this post


Link to post
Share on other sites

Have you tried disabling any antivirus or security software?

Running as admin as Spawn said can do wonders for XP/9x games since older games expect admin level access.

I'm also left-handed and don't use WASD, I'd share my player.txt file but my keybinds are focused around the numpad 8456 keys.

Share this post


Link to post
Share on other sites
On 5/9/2019 at 2:25 AM, Spawn said:

Checking if you can run keybinding the normal way after running NOLF2.exe and Lithtech.exe as admin is the first thing I would test.

binding crouch to right control should be:

Duck = "##157@ @ "

 

Let us know how it goes :)

admin.jpg

Hello folks. Sorry for the long wait for my reply. I got pneumonia and was really sick for a month.  Ended up in hospital.

Alas it didn't work. Disabling anti-virus doesn't work. I am REALLY stuck.

I'm going to see if I can buy a small WASD or onehanded keyboard/macro to sit on top of my laptop. That's the only solution I have.

Wish I knew why it crashes on Controls.

Thank you all for your help. If you have any other ideas, pls let  me know.

Share this post


Link to post
Share on other sites

Welcome back, It sounds like a strange issue indeed. Glad to hear that you're doing better :)

If nothing else works maybe something like this could be helpful for you?

https://www.ebay.com/sch/i.html?_from=R40&_trksid=m570.l1313&_nkw=K13+One+Handed+Gaming+Keyboard&_sacat=0

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this