Sign in to follow this  
NOLFFAN

NOLF 2 Laggy

12 posts in this topic

Hi

I got a new PC and decided to go through soem of my games.When i got to NOLF 2,i was noticing some bad lag.I then found out that disabling the music might help,and i did.No lag at all.

I tried to run this codec for NOLF 2 but i couldn't.

https://nolfgirl.net/Unityhq/forums/files/file/168-wmfistexe-codec-for-nolf2/?_fromLogin=1

Is there any way that i can have the in game music for NOLF 2 and no lag?.

Sorry if this topic has been covered before.

 

Thansk

 

Colin

Windows 10 Home 64 Bit
Gigabyte Z370 AORUS Ultra Gaming: ATX, LG1151, USB 3.1, SATA 6GBs
Intel Core i7 Six Core Processor i7-8700k (3.7GHz) 12MB Cache
Super Quiet Titan DragonFly Heatpipe Intel CPU Cooler
1TB SEAGATE FIRECUDA 3.5" SSHD
6TB WD BLACK 3.5" WD6001FZWX, SATA 6 Gb/s, 128MB CACHE (7200rpm)
CORSAIR 650W TXm SERIES SEMI-MODULAR 80 PLUS GOLD, ULTRA QUIET
8GB AMD RADEON™ RX 580 - HDMI, 3 x DP - DX 12
8GB AMD RADEON™ RX 580 - HDMI, 3 x DP - DX 12
Creative Sound Blaster Zx 5.1 PCI-E Soundcard
32GB Corsair VENGEANCE DDR4 3000MHz (2 x 16GB)
24x DUAL LAYER DVD WRITER ±R/±RW/RAM
AOC G2770PF HDMI LCD 27 inch Monitor

Edited by NOLFFAN

Share this post


Link to post
Share on other sites

Please move this to NOLF 2 Tech help.Didn't see that sub forum.Sorry.

Share this post


Link to post
Share on other sites

Are you running NOLF 2 in compatibility mode? 

Share this post


Link to post
Share on other sites

Yes i have tried this in various compatibility modes(XP service pack 2 won't launch the game).

According to this link it could be the game has problem with music overlapping when guards enter search mode.

https://pcgamingwiki.com/wiki/No_One_Lives_Forever_2:_A_Spy_in_H.A.R.M.'s_Way#Audio_settings

Thanks

Colin

Share this post


Link to post
Share on other sites
7 hours ago, NOLFFAN said:

Yes i have tried this in various compatibility modes(XP service pack 2 won't launch the game).

According to this link it could be the game has problem with music overlapping when guards enter search mode.

https://pcgamingwiki.com/wiki/No_One_Lives_Forever_2:_A_Spy_in_H.A.R.M.'s_Way#Audio_settings

Thanks

Colin

Are you running any mods? 

Share this post


Link to post
Share on other sites
13 hours ago, NOLFFAN said:

Yes,i'm running the widescreen patch.I'd like to play the game in 1920x1080 resolution.

https://www.play-old-pc-games.com/2015/03/11/noone-lives-forever-2/

Thanks

Colin

 

Try this as well (it works with all the NOLF games)

Share this post


Link to post
Share on other sites

Okay time for an update.

The dgVoodoo 2 2.55 worked okay and there was no lag in game with the music.BUT,i now have blocks where text/subtitles should be.I have gone through the options but can't see anything that could help.Do you know how to solve my problem?.

The problem is with D3D8.dll file,that is corrupting the text/subtitles.

Thanks

Colin

 

Edited by NOLFFAN

Share this post


Link to post
Share on other sites

Not sure on that one. I would assume since the game was never intended to run on 16:9 ratios that it's trying to put the subtitles still in the older 4:3 ratio. 

Share this post


Link to post
Share on other sites

Good news,iv'e managed to get the text problem sorted out.Thanks for all the help.

Colin

Share this post


Link to post
Share on other sites
5 hours ago, NOLFFAN said:

Good news,iv'e managed to get the text problem sorted out.Thanks for all the help.

Colin

I'm curious as to how you resolved it. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this