Sign in to follow this  
Lodingi

Anyway to get 16:9 resolutions?

Recommended Posts

Merry Christmas Nolfers. I just received an LED monitor for Christmas. The native resolution of this monitor is 1920x1080. When playing NOLF2, the maximum resolution is 1280x960. I am not enjoying the game play at this resolution. My previous CRT monitor allowed me to play at 2048x1536 and every resolution in between. I am hoping there is a fix of some sort. I appreciate your input.

Share this post


Link to post
Share on other sites

First of all, nice new theme for this forum!

 

Lodingi, let's see if I'm not confused or thinking in another thing this time!

So the problem is that you can't select the maximum resolution...

For select a custom resolution, simply do this:

 

1) Go to your NOLF 2 main folder.

2) Open the file "display.cfg" with the notepad.

3) Change the values "screenwidth" and "screenheight" for the ones you want!

4) Save the file.

 

If you're changing from 4:3 to 16:9, you can do this for fix the screen proportions:

 

1) Go to your NOLF 2 main folder.

2) Open the "autoexec.cfg" file with the notepad.

3) Change the value "pvmodelfov" to 86.67

4) Save the file.

 

I hope that now all this information is correct and it helps you! (I help to the other members if I can and I've some free time!)

Share this post


Link to post
Share on other sites

Guess I can write in this thread....Also upgraded my screen. My old one from the stone age was good with nolf. The new widescreen one makes the game look...WIDE. Its hard to throw grenades now :P So how can I change the look so its more like before?

 

Thanks and Happy New Year nolfers :D

Share this post


Link to post
Share on other sites

Steps to make your Nolf2 work with widescreen or custom resolutions.

 

1) Open 'display.cfg' under C:\Program Files\Fox\No One Lives Forever 2\

2) Change the value 'Screenwidth' and 'Screenheight' to the resolution that you desire.

3) Save the file.

4) Open 'autoexec.cfg' under C:\Program Files\Fox\No One Lives Forever 2\

5) Find the setting 'pvmodelfov' by using the Find function in Notepad.

6) Change that value (see below).

 

16:10 = 78

16:9 = 86.67

5:4 = 60.9375

 

Share this post


Link to post
Share on other sites

I appreciate the quick response Adrian & E1. I followed your instructions, but for some reason Windows won't allow me to save the changed files. I'm a little confused as I am in Admin mode. Thanks again.

Share this post


Link to post
Share on other sites
I appreciate the quick response Adrian & E1. I followed your instructions, but for some reason Windows won't allow me to save the changed files. I'm a little confused as I am in Admin mode. Thanks again.

 

 

Windows 7?

 

Copy files to desktop.

 

Make file edits.

 

Then copy the files back overwriting what is there presently.

Share this post


Link to post
Share on other sites
I appreciate the quick response Adrian & E1. I followed your instructions, but for some reason Windows won't allow me to save the changed files. I'm a little confused as I am in Admin mode. Thanks again.
Don't worry, it's normal: I had the same problem too. You only need to open the properties of the files and disable the "read only" option. After that, retry and you will can!

Share this post


Link to post
Share on other sites
Windows 7?

 

Copy files to desktop.

 

Make file edits.

 

Then copy the files back overwriting what is there presently.

 

 

That's how I was able to get it working. I did notice the custom resolution does not show in the in game display settings. If I mess with the resolution while in game, I lose that setting and I am now required to edit the display.cfg again. Oh well, small price to pay I guess.

Share this post


Link to post
Share on other sites

I've been playing around with the display resolutions. It appears that changing the resolutions using the methods above, does not give you that resolution natively. Instead it takes a lower resolution (1280x960 for me)& stretches it to 1920x1080. For me, using lower resolutions has a negative effect on gameplay. That and it really hurst my eyes. :crazy:

Share this post


Link to post
Share on other sites

I've been playing around with the display resolutions. It appears that changing the resolutions using the methods above, does not give you that resolution natively. Instead it takes a lower resolution (1280x960 for me)& stretches it to 1920x1080. For me, using lower resolutions has a negative effect on gameplay. That and it really hurst my eyes. :crazy:

 

I prefer keeping the original 'pvmodelfov' setting (65) but changing 'pvmodelaspect' since it keeps PV weapons & gadgets looking the same as they did on a 4x3 display.

 

pvmodelaspect settings

16x10 = 1.439977

16x9 = 1.59995

5x4 = 1.125005

4x3 = 1.2

 

But you should also try my LivesForeverPlus mod, it has greater support for widescreen resolutions and auto FOV settings (doesn't make things look stretched).

Share this post


Link to post
Share on other sites

I prefer keeping the original 'pvmodelfov' setting (65) but changing 'pvmodelaspect' since it keeps PV weapons & gadgets looking the same as they did on a 4x3 display.

 

pvmodelaspect settings

16x10 = 1.439977

16x9 = 1.59995

5x4 = 1.125005

4x3 = 1.2

 

But you should also try my LivesForeverPlus mod, it has greater support for widescreen resolutions and auto FOV settings (doesn't make things look stretched).

 

And how does one test the mod?

Share this post


Link to post
Share on other sites

And how does one test the mod?

 

Download and install if you don't already have it > LivesForeverPlus Download

Select the mod from the custom menu on the launcher and start NOLF2, select your screen resolution in display options in game (if its not already set) and then start a new single player game or host a multiplayer game.

Share this post


Link to post
Share on other sites

Download and install if you don't already have it > LivesForeverPlus Download

Select the mod from the custom menu on the launcher and start NOLF2, select your screen resolution in display options in game (if its not already set) and then start a new single player game or host a multiplayer game.

 

I did as you suggested. Looks like the maximum resolution is 1680x1050. It did feel smooth. Is there a way to get the Lives Forever mod display higher resolutions natively?

 

Came back to edit my post. My comment above is not accurate. I can play the game at high resolutions on my CRT monitor. Getting these higher resolutions, be it 4:3 or 16:9 do not display natively. They are stretched.

Edited by Lodingi

Share this post


Link to post
Share on other sites

I did as you suggested. Looks like the maximum resolution is 1680x1050. It did feel smooth. Is there a way to get the Lives Forever mod display higher resolutions natively?

 

Came back to edit my post. My comment above is not accurate. I can play the game at high resolutions on my CRT monitor. Getting these higher resolutions, be it 4:3 or 16:9 do not display natively. They are stretched.

 

The problem here is that NOLF2, CJ & Tron 2.0 (even FEAR before the v1.08 patch) where made with only standard 4:3 resolutions in mind, so the game ends up being stretched in non-standard resolutions (5:4, 16:10, 16:9, ect).

The only mods for NOLF2 that I know of that support widescreen resolutions more natively are my Weapons-05/a/b & LviesForeverPlus.

 

However I just found out about a few command-line options that are a lot better than the autoexec.cfg & display.cfg edits.

Start NOLF2's launcher and goto options

Copy either the 16:10 or 16:9 line and past it into the command-line

 

16:10

+screenwidth 1440 +screenheight 900 +fovx 100.38 +fovxinterface 100.38 +fovyuwmax 124 +pvmodelfov 65 +pvmodelaspect 1.439977

 

16:9

+screenwidth 1920 +screenheight 1080 +fovx 106.260208 +fovxinterface 106.260208 +fovyuwmax 124 +pvmodelfov 65 +pvmodelaspect 1.59995

 

Change the +screenwidth and +screenheight to match your resolution and check the box next to Always pass command line arguments to the game

 

I also recommend downloading this to help keep things like the chat input and other menu items from running off screen, just place this in LivesForever folder > Wide Screen Menu fix

Share this post


Link to post
Share on other sites

The problem here is that NOLF2, CJ & Tron 2.0 (even FEAR before the v1.08 patch) where made with only standard 4:3 resolutions in mind, so the game ends up being stretched in non-standard resolutions (5:4, 16:10, 16:9, ect).

The only mods for NOLF2 that I know of that support widescreen resolutions more natively are my Weapons-05/a/b & LviesForeverPlus.

 

However I just found out about a few command-line options that are a lot better than the autoexec.cfg & display.cfg edits.

Start NOLF2's launcher and goto options

Copy either the 16:10 or 16:9 line and past it into the command-line

 

16:10

+screenwidth 1440 +screenheight 900 +fovx 100.38 +fovxinterface 100.38 +fovyuwmax 124 +pvmodelfov 65 +pvmodelaspect 1.439977

 

16:9

+screenwidth 1920 +screenheight 1080 +fovx 106.260208 +fovxinterface 106.260208 +fovyuwmax 124 +pvmodelfov 65 +pvmodelaspect 1.59995

 

Change the +screenwidth and +screenheight to match your resolution and check the box next to Always pass command line arguments to the game

 

I also recommend downloading this to help keep things like the chat input and other menu items from running off screen, just place this in LivesForever folder > Wide Screen Menu fix

 

Using the command line seems to have helped. The game feels somewhat smooth. I do have one issue. For some reason, my name has changed to "+screenwidth". I cannot change my name back. Any suggestions?

Share this post


Link to post
Share on other sites

Check your player.txt file to see what your name is in there.

Share this post


Link to post
Share on other sites

Using the command line seems to have helped. The game feels somewhat smooth. I do have one issue. For some reason, my name has changed to "+screenwidth". I cannot change my name back. Any suggestions?

Forgot about that with Join by IP :whistle:

My name has shown up as "+windowed" before, 2 options, either should work:

a. Put your name into the Playername field in Join by IP before playing

b. Put your name in the beginning of the command line (in front of +screenwidth)

Share this post


Link to post
Share on other sites

Darn and i thought "+screenwidth" is a cool new player :rolleyes:

:blink::24:

Share this post


Link to post
Share on other sites

Darn and i thought "+screenwidth" is a cool new player :rolleyes:

 

Nope. Just a grumpy old one.

Share this post


Link to post
Share on other sites

The problem here is that NOLF2, CJ & Tron 2.0 (even FEAR before the v1.08 patch) where made with only standard 4:3 resolutions in mind, so the game ends up being stretched in non-standard resolutions (5:4, 16:10, 16:9, ect).

The only mods for NOLF2 that I know of that support widescreen resolutions more natively are my Weapons-05/a/b & LviesForeverPlus.

 

However I just found out about a few command-line options that are a lot better than the autoexec.cfg & display.cfg edits.

Start NOLF2's launcher and goto options

Copy either the 16:10 or 16:9 line and past it into the command-line

 

16:10

+screenwidth 1440 +screenheight 900 +fovx 100.38 +fovxinterface 100.38 +fovyuwmax 124 +pvmodelfov 65 +pvmodelaspect 1.439977

 

16:9

+screenwidth 1920 +screenheight 1080 +fovx 106.260208 +fovxinterface 106.260208 +fovyuwmax 124 +pvmodelfov 65 +pvmodelaspect 1.59995

 

Change the +screenwidth and +screenheight to match your resolution and check the box next to Always pass command line arguments to the game

 

I also recommend downloading this to help keep things like the chat input and other menu items from running off screen, just place this in LivesForever folder > Wide Screen Menu fix

Is there still a way to get the 'Wide Screen Menu fix'?

Share this post


Link to post
Share on other sites

Is there still a way to get the 'Wide Screen Menu fix'?

From that link, unfortunately no :(

 

However, my Multiplayer Launcher that is hosted here (http://sficlan.net/Unityhq/forums/forums/index.php?app=downloads&showfile=55) includes this file and sets up the screen & fov commands automatically.

Share this post


Link to post
Share on other sites

hello everyone.

 

The 16/9 commandlines work well, but not in cinematics (they are still stretched). Is there a way change cinematics fov?

Share this post


Link to post
Share on other sites

hello everyone.

 

The 16/9 commandlines work well, but not in cinematics (they are still stretched). Is there a way change cinematics fov?

As far as I know, the only option for changing the cinematics fov is with my Lives Forever Plus and Weapons-05b mods.

Unfortunately if you use either mod, you will have to restart from the beginning of the chapter from the chapter list or start a new game.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this