{IF} Crusader

Problems with hosting a server

30 posts in this topic

Hey everybody,

 

Since some weeks I have the following problem: When I want to start a Server in Nolf2 (DM for expamle), everything is fine, until I want to join it! When i join my Server, I alsways get this message: "Can't load the worlds resources" or something like this!

Is there maybe a problem with running a a Nolf2, when I have installed Contract Jack? It worked before, so it is the first time it doesn' work..... as I said since 2/3 weeks! Please help me!

 

My Server-PC has the following componets:

 

Intel Pentium IIIE (997 MHz)

nVidia Geforce 2 Pro

1024 MB RAM

Windows XP SP3 (with all updates)

No One Lives Forever 2 (also including all updates)

Share this post


Link to post
Share on other sites

maybe you have too many .rez files in your maps folder...?

Share this post


Link to post
Share on other sites

Are you sure it says "Can't load the worlds resources" ? As far as I remember, it should say "Unable to load" onstead of "Can't" and if it says "Can't" then it's different error and idk what is it :P

 

Actually this message is popped when u dont have maps installed :huh:

Share this post


Link to post
Share on other sites

Now, I use another port (28888) and I get another message: "You have been banned or kicked from the server"

 

Any ideas? All mappacks installed!

Share this post


Link to post
Share on other sites
Now, I use another port (28888) and I get another message: "You have been banned or kicked from the server"

 

Any ideas? All mappacks installed!

 

 

Are you hosting a dedicated server on your PC and then trying to join it?

If so then you would get that message.

 

Share this post


Link to post
Share on other sites
I host a Server on my Server -PC next to me, and then I try to join with my 2 Computer and I get this errors!

 

Behind a router? Firewall?

Share this post


Link to post
Share on other sites

I use a Router to connect to Internet, and for Nolf2 I use Port 28888, for CJ I use 27888! Nolf2 isn't working with any of these Ports, CJ works with both!

Share this post


Link to post
Share on other sites
I use a Router to connect to Internet, and for Nolf2 I use Port 28888, for CJ I use 27888! Nolf2 isn't working with any of these Ports, CJ works with both!

 

 

Trying to follow what you are trying to do.

For you to connect to the server running on your LAN you would browse to it as a LAN server. Not sure if the join by ip tools supports LAN servers. If you are trying to get it to "broadcast" to the internet then you would need to setup port forwarding on your router(28888 and 28889 for NOLF2 specifically as NOLF2 is scanned that way. Add 1 to the port).

Share this post


Link to post
Share on other sites
Here is a little picture, I hope this will help you understanding me:

 

unbenanntaz.th.png

 

Can't read most of the picture.

 

Sounds like you are trying to host a NOLF2 server behind a router so you can play and others on the internet can play.

 

Do you have two seperate copies of NOLF2? If you are trying to run a server and play with the same copy you'll have issues (you can't connect to the server running as a dedicated server) To do what I think you want to do you'll need two copies of the game and enable the port forwarding on your router.

Share this post


Link to post
Share on other sites
Yes i play with one copie of Nolf2! But tell me, why it was working fine about 5 weeks ago?

 

 

Don't know the answer to that. What did you change 5 weeks ago? That most likely is the cause of your issue.

Share this post


Link to post
Share on other sites

I just reinstalled my XP, nothing else.... Didn't change anything! All mappacks and updates are installed again! Maybe there is a problem with Contract Jack, is this possible?

Edited by {IF} Crusader

Share this post


Link to post
Share on other sites

I don't think it's an issue with CJ... CJ has nothing to do with NOLF2 (as long as you don't try to host 2 servers on the same port...)

 

Are you sure that the ports in your router are open? What protocoll did you choose? For NOLF2 I have to choose UDP.

 

Also make sure, that the dedicated server is running the Lives Forever mod just as well as the PC you are trying to connect with.

Share this post


Link to post
Share on other sites

I posted some pictures for you, I hope they will help you understanding:

 

I don't think it's an issue with CJ... CJ has nothing to do with NOLF2 (as long as you don't try to host 2 servers on the same port...)

 

No, I use two different ports, as you see on my pictures!

 

Are you sure that the ports in your router are open? What protocoll did you choose? For NOLF2 I have to choose UDP.

 

pic1_b10.jpg

 

pic2_b10.jpg

 

Also make sure, that the dedicated server is running the Lives Forever mod just as well as the PC you are trying to connect with.

 

Yep, I checked this!

Edited by {IF} Crusader

Share this post


Link to post
Share on other sites

Does anybody has found out a solution yet?

 

I still have this problems, but in the last week i reinstalled XP and Nolf2 with all Updates and Mappacks and i still have this problem.... Please help! :unsure:

Share this post


Link to post
Share on other sites
Does anybody has found out a solution yet?

 

I still have this problems, but in the last week i reinstalled XP and Nolf2 with all Updates and Mappacks and i still have this problem.... Please help! :unsure:

 

 

Are you running it as a dedicated server then trying to join it on the same machine?

Share this post


Link to post
Share on other sites
Are you running it as a dedicated server then trying to join it on the same machine?

 

You already asked this: Yes dedicated Server and no I try to join with 3 different computers (they all have updates+mappacks, also hoster)

Share this post


Link to post
Share on other sites
You already asked this: Yes dedicated Server and no I try to join with 3 different computers (they all have updates+mappacks, also hoster)

 

I asked again cause I have other things in life besides this particular issue and since you revived the topic after awhile.

 

If all 3 PCs were behind the same router then they would join the "server" as LAN clients not internet.

 

The way to test it would be to have someone outside your router see if they can join it.

Share this post


Link to post
Share on other sites
I asked again cause I have other things in life besides this particular issue and since you revived the topic after awhile.

 

Sorry, that shouldn't be an attack on you, just a statement! :o

 

If all 3 PCs were behind the same router then they would join the "server" as LAN clients not internet.

 

Hmmm, ok.

 

The way to test it would be to have someone outside your router see if they can join it.

 

Ok, i will try this!

Share this post


Link to post
Share on other sites

Hey ƒƒ5•ßahamutZero,

 

Thanks for your help!

 

Some month ago, I was hosting like you decribed it in the video, but the only different was, that I used Mutiplayer (Internet) and my Server was shown in the Join by IP Tools list, so that I must not use custom IP

 

 

 

 

Share this post


Link to post
Share on other sites

Hello again,

 

I am having problems,... again! This time, when I try to host, I get an error, if I want to join:

 

"ERROR - Unable to join the selected game session"

 

Can anybody help me?

Share this post


Link to post
Share on other sites
Hello again,

 

I am having problems,... again! This time, when I try to host, I get an error, if I want to join:

 

"ERROR - Unable to join the selected game session"

 

Can anybody help me?

 

Are you running it as a dedicated server on the same machine?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now