Jump to content

Strange Framerate Stutter


Painboy
 Share

Recommended Posts

I fired up NOLF2 again for the first time in a couple years. Everything runs great with no issues. Except one.

 

The game will have perfect framerate when during certain situations everything begins to stutter. It happens everytime one of the guards gets "suspicious." The framerate will be smooth but as soon as they start looking for me it's like only half or even a third of the frames are getting shown. When they die or go back to normal patrol the frame rate returns to normal. It looks like there is some sort of bottleneck.

 

I have messed around with some of the settings but nothing seems to help. Anyone have any idea what this is and how to fix it?

 

Specs:

AMD Athlon64X2 4800+

Radeon x850xt pe

2 Gig Corsair RAM

Creative SB X-Fi

WinXP

Link to comment
Share on other sites

My guess is you may be playing at a low resolution. This can cause your cpu to bottleneck. Try cranking up the resolution and let the video card handle the work load.

 

1. Open up task manager and click on the performance tab. Leave it open on the desktop.

 

2. Start Nolf and start playing at your normal resolution.

 

3. Alt+Tab to the desktop & check the cpu usage. If it's pegged at 100% it's bottle necking.

 

4. Go back into Nolf, start raising the resolution & continue playing.

 

5. Alt+Tab to the desktop & check the cpu usage again.

 

Keep following these steps until your cpu usage hovers around 50%. At that point your video card has taken the workload off the cpu & your frames should become more stable.

 

If you are using a 17" or 19" LCD monitor you may be restricted to its native resolution. Good luck.

Edited by Lodingi
Link to comment
Share on other sites

Thanks for the fast responses. Actually I'm running it at 1600x1200. The CPU hovers around 50% most of the time. I don't think cpu muscle is the cause as it is otherwise silky smooth other than in one situation.

 

I'm curious is there some sort of cache that might need to be emptied manually?

 

I just can't understand why it only happens in one specific situations consistently.

Link to comment
Share on other sites

Problem solved yet?

 

I believe when the guards change to "search mode", a certain tune is played. Maybe it's a sound problem? For testing, try to turn off everything that has to do with music/sound, and *tadaaaa* incredibly new proposal: update your audio driver. And/or use DxDiag and in the "Sound" tab move the hardware acceleration slider all to the left (no accel).

 

Link to comment
Share on other sites

Realtek chipsets may have soundissues, and will lag when shooting and so on, disabling hardwaresound in the launcher options helps there, However I think there's a lag problem when the ais are chasing you as well on some 64bit systems, dunno.. I've been experiencing that myself a few times.. Not really sure what causes it. But the same thing worked fine on a 32bit system.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines Privacy Policy.