Sign in to follow this  
Dark Savior

no music in windows 2003

Recommended Posts

Hey. I'm on Windows 2003 and can't get NOLF2's music to work. I've tried everything in the Sound Problems sticky topic, but nothing. I can't install WMFADist.exe because it says it's not compatible with my version of windows. Yes even with compatibility mode in xp. Tried to manually copy L3codeca.acm from the WMFAdist package. Also nothing..

 

What's also puzzling is that NOLF1's music won't also play. Neither will Shogo's. On XP the music plays fine.

It's been driving me nuts for years, finally gave up and try asking in here...

 

Specs:

ECS Nforce2

Athlon XP 3200+

Geforce 5200FX

Audigy 2 Value

Share this post


Link to post
Share on other sites

Be sure all audio drivers are correctly installed.

 

And check the following:

Start -> Run -> services.msc -> Start the service: Windows Audio

Share this post


Link to post
Share on other sites

Windows 2003? as in the server OS?

 

 

Share this post


Link to post
Share on other sites

SAssER, yes...new games work perfectly. But for some reason these Monolith games never had music in 2003. Sound effects work fine though. My Audigy2 drivers are the latest, the Audio service is enabled. I really think it's just these odd codecs they use. Maybe if that WMFAdist.exe was made for this os. If anyone knows a manual way to register the codecs inside it let me know.

 

Eliteone. yes. Though it's just technically an updated xp kernel.

Share this post


Link to post
Share on other sites

SAssER, yes...new games work perfectly. But for some reason these Monolith games never had music in 2003. Sound effects work fine though. My Audigy2 drivers are the latest, the Audio service is enabled. I really think it's just these odd codecs they use. Maybe if that WMFAdist.exe was made for this os. If anyone knows a manual way to register the codecs inside it let me know.

 

Eliteone. yes. Though it's just technically an updated xp kernel.

 

 

The server OS has other properties than desktop operating systems. There isn't a driver on the Nolf 2 CD (sound etc) for that operating system. Now you could try to run it in compatibility mode (right click the icon and go to properties, select Windows XP or 2000 and see if that helps.

 

Found a couple articles about this you can check out.

 

http://www.tutorials-ne.com/sdk/Enumerating-audio/

http://www.msfn.org/comments.php?shownews=17228

http://www.west-wind.com/WebLog/posts/4337.aspx

http://forums.creative.com/creativelabs/bo...;message.id=291

Share this post


Link to post
Share on other sites

Just tried the cmedia internal soundcard and also had the same problem.

 

Thanks, ill take a look at those articles.

Share this post


Link to post
Share on other sites

sorry none of those articles helped. My soundcard is installed just fine. Every game i've installed has had no problem EXCEPT these...

 

thanks anyways, ill try and figure out the codec thing..

Share this post


Link to post
Share on other sites

sorry none of those articles helped. My soundcard is installed just fine. Every game i've installed has had no problem EXCEPT these...

 

thanks anyways, ill try and figure out the codec thing..

 

 

Have you tried running it in compatibility mode?

Share this post


Link to post
Share on other sites

In the launcher (before you click Play to start the game) you can try to click options and disable DirectSound 3D or Hardware-Sound maybe that helps

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this